Bug 213113 - NM should honor default wpa_supplicant configuration for a given ESSID
NM should honor default wpa_supplicant configuration for a given ESSID
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 15:51 EST by Pavel Polischouk
Modified: 2008-01-03 12:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 12:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Polischouk 2006-10-30 15:51:32 EST
Description of problem:

In my setup, wpa_supplicant is able to authenticate with the access point using
its own configuration file. NetworkManager thrashes this configuration, and is
unable to configure wpa_supplicant to do the same. 
The reason why NM is unable to configure the supplicant properly is a matter for
another bug. This one is about missing "select AP->use default WS config"
functionality. The only workaround for now is to completely disable NM.

Version-Release number of selected component (if applicable): 0.6.4-5.fc6


How reproducible: Always


Steps to Reproduce:
1. Create working wpa_supplicat.conf
2. Start NetworkManager
  
Actual results:
No auth.

Expected results:
Should authenticate properly as soon as requested ESSID is selected in NM-applet
Comment 1 Dan Williams 2008-01-03 12:48:14 EST
NM uses the D-Bus config interface, not the wpa_supplicant config file. 
Configuration information for NM is kept in a more unified format for the user
and in the distros default format (/etc/sysconfig/network-scripts/ifcfg-*) for
system connections.  Using wpa_supplicant.conf doesn't really provide and
benefit and is the wrong place to store the information.

Note You need to log in before you can comment on or make changes to this bug.