Bug 21312 - Mysterious rhn_check offers no help.
Summary: Mysterious rhn_check offers no help.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-24 21:17 UTC by Idcmp
Modified: 2015-01-07 23:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 20:10:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Idcmp 2000-11-24 21:17:46 UTC
No clue what rhn_check does since up2date doesn't include an ounce of
documentation, but it gives nice python errors when you run it with --help
or -help

---
[root@respect /root]# rhn_check -help
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 370, in ?
    ["verbose"])
  File "/usr/lib/python1.5/getopt.py", line 60, in getopt
    opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
  File "/usr/lib/python1.5/getopt.py", line 102, in do_shorts
    if short_has_arg(opt, shortopts):
  File "/usr/lib/python1.5/getopt.py", line 117, in short_has_arg
    raise error, 'option -%s not recognized' % opt
getopt.error: option -h not recognized

Comment 1 Preston Brown 2000-11-28 19:51:32 UTC
Cristian, you should document this.

Comment 2 Cristian Gafton 2001-02-20 01:33:45 UTC
Assigned QA to jturner

Comment 3 Adrian Likins 2001-07-06 02:24:05 UTC
Current versions of up2date include man pages for all the utilities
that are meant to be ran by a user. The next version also includes
man pages for rhn_check


Note You need to log in before you can comment on or make changes to this bug.