Bug 213136 - Should handle PPDs with On/Off bools
Summary: Should handle PPDs with On/Off bools
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2006-10-30 22:13 UTC by sean
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.7.35-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 17:13:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of system-printer-config (77.99 KB, image/png)
2006-11-01 14:57 UTC, sean
no flags Details
ppd file from windows driver for Dell 1600n (22.80 KB, application/octet-stream)
2006-11-04 12:50 UTC, sean
no flags Details

Description sean 2006-10-30 22:13:20 UTC
Description of problem:

I have a Dell 1600n MFC on another subnet. I ( on 10.10.8.1 ) print using:

lpd://192.168.2.250/lpt1

If I don't have a the ppd installed, and just treat it as a raw printer, I can
print the test page.

But, I've installed the windows ppd file. Now I can't print a test page.

But printing does work, except that it keeps printing two pages on one ( which
is why I wanted to print the test page ).

I can print the test page from the cups web interface.

BTW, the ppd browser only select .ppd files. Most windows ppd files are .PPD,
which the browser does not allow.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 sean 2006-10-30 22:14:29 UTC
system-config-printer-0.7.32-1.x86_64
cups-1.2.5-3.fc7.x86_64

But same on FC6 install. I upgraded to see if it fixed it.

Comment 2 Tim Waugh 2006-10-31 11:38:56 UTC
(I've filed bug #213223 to track the '.PPD' bug -- thanks.)

I'd like to get some more information:

1. Could you please run system-config-printer from a terminal window and try
printing a test page again, to see if there are any error messages?  (Make a
note of the time you clicked 'print test page'..)

2. Could you please attach the /var/log/cups/access_log messages from the time
you tried printing the test page?

Thanks.

Comment 3 sean 2006-11-01 02:13:21 UTC
I explained this poorly.

The print test page button is "grayed out". There's nothing to click.

I tried anyhow - nothing.

Comment 4 Tim Waugh 2006-11-01 12:25:48 UTC
Are all three check-boxes to the left of the test page button checked?

Comment 5 sean 2006-11-01 14:57:31 UTC
Created attachment 139983 [details]
screenshot of system-printer-config

Comment 6 sean 2006-11-01 14:58:35 UTC
Yes, they're all checked.

FWIW, this is the Default Printer.

I've attached a screenshot.

Comment 7 Tim Waugh 2006-11-01 15:16:43 UTC
The 'Apply' button is sensitive, which indicates that s-c-printer thinks there
are unapplied changes.  Is it correct?

If not, I wonder if you could run 'system-config-printer' from a terminal window
for me, and see if there are any messages there that would indicate why it
thinks that.

Comment 8 sean 2006-11-01 23:00:01 UTC
I had just brought up s-c-p. Nothing to Apply.

But, I did bring it up from a terminal window. Both Revert and Apply were
sensitive. Without making any changes, clicked both. Both stayed sensitive.

No messages in the terminal.

Comment 9 sean 2006-11-01 23:17:44 UTC
Further, s-c-p always thinks I have changes to apply for this printer. If I
restart cups, and then start s-c-p, it always asks me if I want to save changes
when I switch to another printer. But if I'm on the inkjet ( the other printer),
the Revert and Apply buttons are grayed out, and I don't get the pop-up when I
switch back to this printer.

Comment 10 Tim Waugh 2006-11-02 10:08:01 UTC
Would you mind attaching the PPD file for this printer please?  Thanks.

Comment 11 sean 2006-11-04 12:50:30 UTC
Created attachment 140353 [details]
ppd file from windows driver for Dell 1600n

Comment 12 Tim Waugh 2006-11-04 17:23:43 UTC
Thanks.  Ah, that PPD has got a Boolean option with 'Off' and 'On' (instead of
'False' and 'True') as choices, which isn't technically valid.

I'll add some special case code to handle this.

Comment 13 sean 2006-11-05 13:54:24 UTC
Thanks for all the help.

I really appreciate the quick response.

Comment 14 Tim Waugh 2006-11-07 14:10:16 UTC
Please try this test update when it gets pushed to the mirrors:

https://www.redhat.com/archives/fedora-test-list/2006-November/msg00134.html

You will be able to update to this package using:

  yum --enablerepo=updates-testing update 'system-config-printer*'

Comment 15 Fedora Update System 2006-11-09 17:02:27 UTC
Fixed in update: system-config-printer-0.7.35-1.fc6

Comment 16 sean 2006-11-10 21:18:35 UTC
system-config-printer-0.7.35-1.fc7.x86_64

works for me.

Thanks


Note You need to log in before you can comment on or make changes to this bug.