Bug 213160 - anaconda's reboots when swap is already enabled
anaconda's reboots when swap is already enabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 19:14 EST by james
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 17:51:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2006-10-30 19:14:42 EST
Description of problem:
swap is already enabled by hand.  anacondo tries to enable swap, fails, and
reboots the machine!

Are you guys stupid or just mean-spirited????!  What, you can't check to see if
the swap partition is enabled????

And this after spending an hour clicking on a custom configuration, which, you
refuse to save!

Version-Release number of selected component (if applicable):
FC6

How reproducible:
Every time.


Steps to Reproduce:
1.start swap by hand after error message about no swap space.
2.
3.
  
Actual results:
Another wasted hour of time.


Expected results:
Who knows?


Additional info:
This is a hard drive install, since NFS does not work.
Comment 1 Jeremy Katz 2006-10-30 19:35:59 EST
We expect that we're going to do all of the mounting of filesystems (including
enabling swap) ourselves.  Why are you having to do otherwise?
Comment 2 james 2006-10-31 17:04:14 EST
There was an error message that came up, something about "There is not enough
memory.  We will have to re-write your partition table now.  Is that ok?"

Well, _no_, it's not ok!  Don't touch my partition table.  And, _no_, the
partition table doesn't have anything to do with the swap partition.

So, I just enable swap by hand.

Now, I just have to _disable_ it by hand before this fragile re-enable of swap
by anaconda.

So, why do you want to argue about it?  Why can't you just check to see if swap
is enabled?  Or just start the install anyway when there is enough memory?  This
is just another of a seeming infinitude of pointless conditions that cause an
install to fail.
Comment 3 David Cantrell 2006-10-31 17:15:20 EST
Do you mean this message:

As you don't have much memory in this machine, we need to turn on swap space
immediately.  To do this we'll have to write your new partition table to the
disk immediately.  Is that OK?

We can't enable swap until we have the partition table written to disk.  And
that has to happen if you've configured your partitions in anaconda.

But I have to go with Jeremy here... anaconda expects to do everything.  If you
do something behind its back, don't expect that it'll know about it.  Why are
you enabling swap by hand?  You should never have to do that.  Anaconda will do
that for you automatically.

Perhaps you could describe your installation scenario in more detail so we can
understand how you are trying to install.
Comment 4 james 2006-10-31 17:40:46 EST
There is no point in discussing this if you don't respond to what I said.  Let
me say it again:

 DO NOT TOUCH MY PARTITION TABLE!

and similarly,

 DO NOT THREATEN TO TOUCH MY PARTITION TABLE!

Now, notice that the anaconda installer has an option for customizing the
partition table.

You can't have it both ways - If there are configurable selections in the
installer, then the installer should not break if someone actually uses them. 
Otherwise, simply remove _all_ the configuration options in the installer, and I
can look for another linux distribution.
Comment 5 David Cantrell 2006-10-31 17:51:56 EST
You are being way more hostile than necessary.  If your bug report is simply
going to be "don't touch the partition table", then I'll have to close this as
WORKSFORME because, frankly, you are being less than helpful in actually
reporting the issue.
Comment 6 james 2006-10-31 18:27:00 EST
Yes, and way more upset and frustrated than necessary.

Oh, I have to assume that we both understand the issue.  I don't want anaconda
changing my partition table, and you don't want to add a line to check for
swapspace.

You might as well close the bug.  The fragility of anaconda is the kind of thing
I might normally ascribe to inexperienced student programmers, but - hey - it's
your software.

Note You need to log in before you can comment on or make changes to this bug.