Bug 213162 - Windows don't remember transparency settings when closes and reopened
Summary: Windows don't remember transparency settings when closes and reopened
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-31 00:24 UTC by Rodd Clarkson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 22:15:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rodd Clarkson 2006-10-31 00:24:18 UTC
Description of problem:

Being able to set windows as transparent offers some interesting options, but
sadly, when you set the transparency of a window, the state isn't remembered the
next time you open it.

For example, the Send and Receive Mail dialog in Evolution which come up each
time it's opened as solid, regardless of the transparency level set the last
time it was used.

Transparency should be like size (and location) which is remembered when the
window closes and then reused when opened (although sadly location seems to be a
bit of a black art).


Version-Release number of selected component (if applicable):

compiz-0.0.13-0.32.20060817git.fc6

Comment 1 k3dzngrp8w2xtc9 2007-01-12 23:52:39 UTC
Try Devil's Pie which can remember and set transparency of windows among other
thinges.

http://live.gnome.org/DevilsPie

Comment 2 Kristian Høgsberg 2007-08-14 22:15:14 UTC
When an application remembers the size and position of it's window, it's
something the application implements.  Either using the session protocol or in
gconf or similar.  In other words, it's something the application needs to support.

I would look into DevilsPie as suggested in comment #1.
 


Note You need to log in before you can comment on or make changes to this bug.