Bug 213170 - x86_64 radeon display flickering on and off
x86_64 radeon display flickering on and off
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 20:22 EST by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-28 12:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8790 None None None Never

  None (edit)
Description Tom Horsley 2006-10-30 20:22:30 EST
Description of problem:

See https://bugs.freedesktop.org/show_bug.cgi?id=8790 for all the
gory details.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.6.2-4.fc6

How reproducible:

Random, but so frequent as to be unuseable.

Steps to Reproduce:
1. Try to use radeon driver with Westinghouse LVM-42w2 monitor at
native 1920x1080 resolution.
2. Watch display turn on and off.
  
Actual results:

At random, the display turns off, then turns back on, then turns off,
etc. Cycle time ranges from a fraction of a second to sometimes
stabalizing and staying on. Even if it is in a stable mode, if you
turn the monitor off and come back later, or let the screen power saver
kick in, you are likely to see the unstable operation again when you
turn monitor back on.

Expected results:

Nice stable picture like I had in Fedora Core 5 with the xorg 7.0
release on x86_64.

Additional info:

The main new piece of information that led me to submit this as a fedora
bug (instead of sticking with xorg) is that (so far - knock on wood), the
i686 version of Fedora Core 6 has been running on the same hardware with
a rock solid display. This leads to lots of wild conjectures like x86_64
build problem, or compiler problem, or 64 bit porting problem in the code.
Since some of those conjectures fall in the fedora domain, I decided to
add this fedora bug.

I'll update the info in the xorg bug if the flickering crops up in the
i686 version.
Comment 1 Matěj Cepl 2006-12-28 12:44:35 EST
Apparently you forgot to add this promised information and I suspect that this
all should be UPSTREAM bug. Correct me if I am wrong, but for now, I am closing
this as an upstream problem.

Note You need to log in before you can comment on or make changes to this bug.