Bug 213176 - mouse drawn on left side of screen after resume from hibernate
mouse drawn on left side of screen after resume from hibernate
Status: CLOSED DUPLICATE of bug 204599
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-10-30 21:18 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-01 08:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-10-30 21:18:05 EST
Description of problem:

On my Dell XPS M1210 laptop with intel (Intel Corporation Mobile
945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)) graphics,
after resuming from hibernate, the mouse is drawn on the left side of the
screen. It follows y axis movements correctly but x doesn't change. The mouse is
working correctly though as different windows on the screen receive focus on
movement. I'm using compiz with mouse focus. The mouse is just not being drawn
correctly, always with x=0 or close to it and y correctly.

Version-Release number of selected component (if applicable):


How reproducible:

I believe it's true after every hibernate.
Comment 1 Thomas J. Baker 2006-10-30 21:28:23 EST
OK, so I just hibernated again and this time, the mouse is stuck at the top of
the screen, moving left and right but not up and down. Again, it is a mouse
drawing issue as the mouse is really moving but not being drawn correctly.
Comment 2 Matěj Cepl 2006-10-31 08:38:34 EST
Does this happen even when you just switch to VT1 (via Ctrl+Alt+F1) and back?
Comment 3 Thomas J. Baker 2006-10-31 08:47:46 EST
Yes, switching to VT1 and back causes the problem. 

I also have problems with video being restored after suspend but I figured I
should open a different bug?
Comment 4 Matěj Cepl 2006-11-01 08:21:18 EST

*** This bug has been marked as a duplicate of 204599 ***
Comment 5 Matěj Cepl 2006-11-01 10:01:37 EST
Thomas, do you have switched on compix (i.e., System/Preferences/Desktop Effects
is on)? If yes, could you, please, try to reproduce the bug with this setting
switcehd off? Thank you.

Note You need to log in before you can comment on or make changes to this bug.