This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 21318 - Bootup halts on init
Bootup halts on init
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-24 20:18 EST by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 01:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-24 20:18:40 EST
I did a workstation install onto my PIII/450 w/ 128mb and a Toshiba MK2016GAP.  I partitioned it with Partition Magic such that hda1->3Gb 
ext2, hda2->128Mb swap, hda3->extended, hda5->FAT32.  I installed Redhat 7 just fine and could boot up fine but then I moved the hardrive 
into my Netpliance I-opener.  I used to have Redhat 6.2 working in the I-opener but decided to get a bigger hard drive and upgrade.  Now it will 
boot up and gets to

VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed.

and then hangs.  I've tried using init=/bin/bash, init=rc.sysinit, and init=/sbin/init but none made any difference.  I have the basic MS-DOS 
system files on hda5 and the dos lilo option will boot dos fine.
Comment 1 Bill Nottingham 2000-11-28 00:44:44 EST
What happens if you try 'init=/bin/ash.static'?
Comment 2 Need Real Name 2000-11-28 01:08:20 EST
it gets to:

VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
# 

and then fails.  The "#" sign is new.
Comment 3 Bill Nottingham 2000-11-28 01:13:18 EST
That's not failing - that's a shell prompt. :)

Unless you're saying the machine is hung at this point?
Comment 4 Bill Nottingham 2000-11-28 01:14:04 EST
If it's not hung, what happens if you run:

/bin/bash

from that shell prompt?
Comment 5 Need Real Name 2000-11-28 01:24:50 EST
It says

# /bin/bash
Illegal instruction
Comment 6 Bill Nottingham 2000-11-28 01:27:42 EST
What kind of processor is in the iopener?

What most likely happened is that when you installed the drive, the
i686 glibc package got installed. This package contains instructions
that won't run on less than a PPro.
Comment 7 Bill Nottingham 2000-11-28 01:29:47 EST
BTW, you can tell what architecture glibc you have by running:

rpm -q --qf "%{ARCH}\n" glibc
Comment 8 Need Real Name 2000-11-28 01:34:54 EST
Well that makes sense because I'm pretty sure its a Rise mp6 200Mhz processor (i586).  If that's it then what steps do I need to do?  Just remove the 
i686 glibc rpm and install the i586 glibc rpm?
Comment 9 Bill Nottingham 2000-11-28 01:37:10 EST
i386 glibc RPM actually (there's only an i386 and i686; adding specific
i586 optimizations doesn't actually help any), but yes, that's
what you'll have to do.
Comment 10 Bill Nottingham 2000-11-28 01:38:52 EST
You'll also want to check to make sure you aren't running an i686
kernel (although that would be likely to die a lot earlier in
the boot sequence...)

Note You need to log in before you can comment on or make changes to this bug.