Bug 21320 - linux 2.2.17 can't compile.
linux 2.2.17 can't compile.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-24 20:59 EST by Steven Ao
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-24 20:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Ao 2000-11-24 20:59:04 EST
Linux 2.2.17 can't compile and it only happens in Redhat 7, worked fine in 
Redhat 6.2. The following is the error output.

make[1]: Entering directory `/usr/src/linux-2.2.17/arch/i386/lib'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.2.17/arch/i386/lib'
cc -D__KERNEL__ -I/usr/src/linux-2.2.17/include -D__ASSEMBLY__  -
traditional -c checksum.S -o checksum.o
checksum.S:231: badly punctuated parameter list in #define
checksum.S:237: badly punctuated parameter list in #define
make[2]: *** [checksum.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.2.17/arch/i386/lib'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.2.17/arch/i386/lib'
make: *** [_dir_arch/i386/lib] Error 2
Comment 1 Jakub Jelinek 2000-11-25 03:26:21 EST
2.2 kernels cannot be compiled by 2.96 compiler (due to kernel
issues, there are patches floating around to make it compile), there
is a kgcc compiler in the distribution which should be used instead.
If you compile 2.2.18pre and above, it should pick it up automatically,
otherwise you should specify it on kernel command line.
make CC='kgcc -D__KERNEL__ -I$(HPATH)'
The failure above is caused by using GCC extensions in traditional
preprocessor (where they are purposedly not implemented after
split of preprocessors), so in this case removing of -traditional
fixes it.

Note You need to log in before you can comment on or make changes to this bug.