Bug 21321 - samba compiled without cups support
samba compiled without cups support
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-25 00:36 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 19:29:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-25 00:36:42 EST
Samba is compiled without CUPS support.  You need to delete Patch11 from
the spec file, and the %patch11 tag.  There was a comment that libcups.a
was required to compile--this is true; however, libcups.a is not required
to run samba, and having CUPS compiled into samba does not require that you
actually have and/or use CUPS.  Please fix this bug in your spec file.

It's very annoying to install RedHat tested and approved packages, only to
find out that critical bits of given applications have been left out (even
though having them in and not using them does not adversely affect system
performance), and having to re-write your spec files and recompile/install
the borked application.
Comment 1 Bill Nottingham 2000-11-25 00:43:33 EST
Actually, enabling cups support makes the package *require* cups,
as it's linked in as a shared library.
Comment 2 Bill Nottingham 2000-11-25 00:44:21 EST
(FYI, we did build it like this for a while, which is how we found
this out.)

We really won't make packages in the distro have shared library
requirements that aren't in the base distribution.
Comment 3 Need Real Name 2000-11-27 19:29:05 EST
Samba compiled with CUPS support does not require that cups be installed.  I can
say that with personal experience.  I currently have samba 2.0.7 installed on
one of my machines.  It supports cups.  It was compiled on a box that had cups
installed.  It is currently installed and running on a box that does not have
CUPS installed.  Samba compiled with CUPS support does not require that you have
CUPS libraries installed; furthermore, it is a trivial enough addition that
having it compiled to support CUPS does not create any overhead. 

With due respect to the work that you guys do, you are incorrect in this
matter.  As a company I view RedHat as trying to make things easier for its
users.  Such things as compiling CUPS support into samba--which contrary to your
responses does *not* require and CUPS libs to be installed alongside the samba
installation--shows people what your company thinks of them.  The fact that you
actually went out of your way to delete CUPS support (which is surprising since
it seems RedHat is trying half-heartedly to promote this excellent system)
indicates that RedHat either has not researched effectively all of the
implications for something so simple. Which I understand is a monumental
task--you guys can't catch everything.  Which is why people like me file reports
like this.
Comment 4 Bill Nottingham 2000-11-28 01:45:11 EST
What you're saying we should do is ship a samba package that will
be different than one built on a full install (since the full install
won't have cups installed, you can't build cups support into
samba). This is not an option.

Note You need to log in before you can comment on or make changes to this bug.