Bug 213215 - Extension GLX is broken
Extension GLX is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 05:40 EST by Patrick Monnerat
Modified: 2013-04-30 19:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.2-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 07:03:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Monnerat 2006-10-31 05:40:28 EST
How reproducible:


Steps to Reproduce:
1. Open a vnc session
2. Start a program using extension GLX
  
Actual results:
The program stops because GLX is not supported

Expected results:
Program running

Additional info:
vnc-4.1.2-3.fc6
There is already a patch included in the source to enable "BuildGlxExt", but 
the makefiles ignore this token.
In other words, GLX seems completely broken in vnc!
Comment 1 Adam Tkac 2006-11-01 04:33:52 EST
Could you please give me link for glx application that doesn't run??
Comment 2 Patrick Monnerat 2006-11-01 06:13:36 EST
I tried with googleearth (http://dl.google.com/earth/GE4/GoogleEarthLinux.bin), 
that revealed the problem (start it from a terminal to see its error messages). 
Blender should do it too, but i did not check.
Comment 3 Adam Tkac 2006-11-01 10:10:16 EST
hmm, I have 2 machines - m1 & m2

m2$ ssh -X m1
m1$ vncviewer :0

and in vncviewer I've started googleearth program and all works fine. Could you
please specify more your reproduction??
Comment 4 Patrick Monnerat 2006-11-01 11:39:09 EST
I do not understand quiet well your test conditions. Where is the vnc server ?
Which graphic environment is displayed by m1's vnc window.
IMHO, I think the problem is that GLX support is not compiled into the vnc
SERVER (/usr/bin/Xvnc). The client is of little importance, since it only deals
with the RFB protocol. Rendering is done in the SERVER.

The conditions in wich the problem occurs:
Machine m1: FC6 dynamic vnc server. Configuration info:

1) /etc/services:
 .
 .
 .
vnc-1600-1200x24   5935/tcp

2) /etc/xinetd.d/vnc-1600-1200x24:
service vnc-1600x1200x24
{
        socket_type     = stream
        wait            = no
        user            = root
        log_on_failure  += USERID
        server          = /usr/bin/Xvnc
        server_args     = -inetd -once -query localhost -geometry 1600x1200 -dpi
100 -depth 24 -fp unix/:7100 -securitytypes=none
        disable         = no
}

3) Restart xinetd
4) Enable local XDMCP, restart display manager.


machine m2 is an FC4 workstation: in a terminal window, submit command
vncviewer m1:35

... but again, I do not think the viewer version/os/etc. is involved in the problem.

The command on m2 above tells m1's xinetd to launch a new vnc server and start a
session with the login screen.

Once logged-in (in m1), open a terminal (on m1 via the m2 vnc window) and launch
googleearth.
Comment 5 Radek Vokal 2006-11-08 07:43:55 EST
Does it really make sense to have accelerated Vnc X server? That would require
bunch of opengl libraries to be added and I don't see any revenue for this. 
Comment 6 Patrick Monnerat 2006-11-08 08:19:50 EST
It does make sense, of course: Although the animations are "jumpy", it allows 
to remotely run programs optimized for accelerated graphics that would'nt 
otherwise accept to run at all !

By the way, I applied the "BuildGlxExt" (opengl) patch on the FC4 version of 
VNC (4.1.1-11.fc4): the resulting vnc-server package supports successfully GLX 
applications under FC4 via any vnc client...
Comment 7 Adam Tkac 2006-11-18 12:13:45 EST
I've fixed glx extensions. Could you try to reproduce with vnc-4.1.2-6.fc7,
please? Thanks
Comment 8 Patrick Monnerat 2006-11-20 05:35:53 EST
Tested vnc-4.1.2-6.fc7 server with blender on FC6: it works great !
Comment 9 Patrick Monnerat 2006-11-29 11:47:18 EST
FYI: GLX is a catastrophe with vnc-4.1.2-7.fc7 ...

Starting blender from the menu makes a white window with a very large gray 
frame to blink(i.e: appear and disappear quickly), then it stays steady with a 
black window (without window manager items). It is possible to stop blender via 
Alt+Q.

Starting blender from a terminal blackens the whole screen immediately. It is 
possible to recover via Alt+Q.

By adding option -render to Xvnc, it works OK!

Many thanks for your work
Comment 10 Adam Tkac 2006-11-30 09:55:30 EST
Looks like big conflict between render & glx extensions. In next release I'm
going turn off both of these extensions by default and you could start glx
extensions with +glx

Note You need to log in before you can comment on or make changes to this bug.