Bug 213220 - Broken Evolution Icons
Broken Evolution Icons
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 06:02 EST by Nuno Carvalho
Modified: 2008-03-11 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 22:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Main evolution wuindow, only New icon. (153.34 KB, image/png)
2006-11-12 16:28 EST, James Antill
no flags Details
Evolution edit menu showing icons in menus (14.42 KB, image/png)
2006-11-12 16:30 EST, James Antill
no flags Details
Main evolution window, with no icons (153.34 KB, image/png)
2006-11-12 16:33 EST, James Antill
no flags Details
Screenshots of evolution with and without gnome-settings-daemon running (72.32 KB, application/x-gzip)
2006-11-14 00:13 EST, Jan Petersen
no flags Details
No icons in Fedora 8 (17.92 KB, image/gif)
2008-03-05 21:43 EST, Jan Petersen
no flags Details

  None (edit)
Description Nuno Carvalho 2006-10-31 06:02:29 EST
Description of problem:
Evolution doesn't show icons of menu and message items when using KDE. AFAIK I
have all packages that it needs (see below) and set the icons to use the Default
GNOME theme, but it doesn't help neither. This bug was present on FC5, hoped
that it would be resolved in this version.

Version-Release number of selected component (if applicable): 
evolution-2.8.0-7.fc6
kde-3.5.4-2.fc6
redhat-menus-6.7.5-3
gnome-icon-theme-2.16.0.1-2.fc6

How reproducible:
Alwways

Steps to Reproduce:
1. Start Evolution.
2. Many icons are missing
3.
  
Actual results:
Missing icons.

Expected results:
Icons were present
Comment 1 Jan Petersen 2006-11-05 17:22:39 EST
Hi

Confirmed here.
Did a fresh install of Core 6, and all icons in evo was missing.
I applied the known work-around of installing gnome-settings-daemon and copying
it to ~/.kde/Autostart

Seams as if a minimum gnome install is needed even if kde only installation is
selected during install.

Note: I just switched from SuSE with did exactly that.
Comment 2 James Antill 2006-11-08 16:49:42 EST
 I have the same problem after upgrading from FC5 via. yum, I'm using GNOME as
my default desktop and appear to have the right gnome-settings-daemon

% rpm -qf /usr/libexec/gnome-settings-daemon
control-center(1:2.16.0-9.fc6).i386

...and it is running. One somewhat strange thing is that I do have icons in the
menubar, and have an icon for the "new" toolbar button but all other toolbar
buttons are blank.
Comment 3 Matthew Barnes 2006-11-10 23:00:29 EST
Could you please post a screenshot or two showing the missing icons?
That would be most helpful.
Comment 4 James Antill 2006-11-12 16:28:13 EST
Created attachment 141008 [details]
Main evolution wuindow, only New icon.

 This is the main evolution window.
Comment 5 James Antill 2006-11-12 16:30:36 EST
Created attachment 141009 [details]
Evolution edit menu showing icons in menus

 This is the edit menu, note that the icon for delete is visible even though
the mark for deletion toolbar icon isn't there.
Comment 6 James Antill 2006-11-12 16:33:03 EST
Created attachment 141010 [details]
Main evolution window, with no icons

 Sorry, this is the main evolution window. The first upload was the mail
display window.
Comment 7 Jan Petersen 2006-11-14 00:13:00 EST
Created attachment 141130 [details]
Screenshots of evolution with and without gnome-settings-daemon running

Hi

Seams your problem is slightly different than mine.
Is this two different problems?

One screenshot is taken while the work-around of placing gnome-setting-daemon
in ~/.kde/Autorun is active. The other where the workaround is removed (well I
stopped the daemon).

Br
Jan
Comment 8 Nuno Carvalho 2006-11-14 05:52:10 EST
Hi

Resolved this issue with the workaround, thanks
Comment 9 James Antill 2006-12-12 19:17:14 EST
 My problem persists with: evolution(0:2.8.2.1-2.fc6).i386

 An strace shows it opening
/usr/share/icons/gnome/24x24/stock/navigation/stock_previous.png ... and that
file exists, and contains data. But there is still no buttons in the toolbar
(apart from new).
Comment 11 James Antill 2007-08-03 23:16:51 EDT
 Well I'm still experiencing it on Fedora 7 i386 -- although x86_64 seems to
work fine.

% rpm -q hicolor-icon-theme
hicolor-icon-theme(0:0.10-2).noarch
% rpm -q gnome-icon-theme
gnome-icon-theme(0:2.18.0-1.fc7).noarch
% ps axuw | egrep '[g]nome-settings-dae'
james     3242  0.0  0.0 298612  3320 ?        Sl   Jul06   1:08
/usr/libexec/gnome-settings-daemon
Comment 12 Matthew Barnes 2007-12-11 15:54:42 EST
I learned recently that KDE does not look at "stock" icons.
e.g. /usr/share/icons/gnome/24x24/stock/navigation/stock_previous.png

To solve this, I think icon-naming-utils would need to set up appropriate
KDE-compatible symlinks for these stock icons.

But first, how's it looking in Fedora 8?  Evolution has been transitioning to
standard icon names [1] and I think most of them should be fixed now.

[1] http://standards.freedesktop.org/icon-naming-spec/latest/
Comment 13 James Antill 2007-12-11 16:35:57 EST
 Note that I'm not using KDE, I have a GNOME desktop with session etc. ...
pretty much default, I think.
 I've moved to evolution.x86_64 only ... as evolution seems 64bit cleanER now.
So it has icons in the main window now (last I tried in Fed-8 i386 it didn't
have them, but that was an update or two ago).
 
 When I click "reply" it randomly doesn't have icons in the sending window ...
it's not all the time, and I don't think it happens when I do "new" (indeed it
seems to happen more often when I do reply to sender instead of reply to all).
But I don't need to reboot or anything, it'll just come back the next time I hit
reply.
Comment 14 Milan Crha 2008-02-11 13:10:46 EST
Moving to Fedora 8.
Comment 15 Jan Petersen 2008-03-05 21:43:09 EST
Created attachment 296984 [details]
No icons in Fedora 8

Running Fedora 8, and still no icons
Comment 16 Milan Crha 2008-03-06 04:39:22 EST
This happened to me only once or twice, no idea why, I just closed Evolution (I
have it running in the session start), and then run it again from the console.
Icons were back. For me it could be some timing issue when the required software
runs a bit slower than Evolution, but that's just a guess.
(With running from console I meant evolution --force-shutdown && evolution)
Comment 17 Jan Petersen 2008-03-06 12:47:37 EST
This is persistent for me in F8. I have to run gnome-settings-daemon in
~/.kde/AutoRun to get the icons back (just is in Fedora 6 and Fedora 7)

I'm on x86_64
Comment 18 Matthew Barnes 2008-03-11 22:44:33 EDT
Original issue a was one of the FAQs from Evolution users [1], so closing as
NOTABUG.  Others have piled on other icon-related issues.  Please open separate
bug reports for these.

[1]
http://www.go-evolution.org/FAQ#I_upgraded_Evolution_-_where_are_my_icons_gone.3F_I_only_get_red_crosses

Note You need to log in before you can comment on or make changes to this bug.