Bug 213234 - Xorg crashes with savage driver
Xorg crashes with savage driver
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 07:36 EST by Pedro Fernandes Macedo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 09:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (56.60 KB, text/plain)
2006-10-31 07:36 EST, Pedro Fernandes Macedo
no flags Details
xorg.conf (2.61 KB, application/octet-stream)
2006-12-29 06:01 EST, Pedro Fernandes Macedo
no flags Details
Xorg log running without xorg.conf (50.45 KB, text/plain)
2006-12-29 06:02 EST, Pedro Fernandes Macedo
no flags Details

  None (edit)
Description Pedro Fernandes Macedo 2006-10-31 07:36:02 EST
Description of problem:

Clean FC6 install. Same hardware worked fine with FC5 without any crashes.
Twice already the X server has crashed in an odd way: the screen turns black and
a cursor blinks for two or three seconds in the upper right corner, before X
restarts.
In the X log, there's usually a backtrace (will attach the log) and in the
kernel log, at the same time a few messages about mtrr and agpgart are generated .

xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drivers-7.1-3
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-server-Xorg-1.1.1-47.fc6


How reproducible: Seems to be somewhat random. Has happened twice since FC6 was
installed last thursday.


Steps to Reproduce: Havent found any ways to reproduce this yet.
Comment 1 Pedro Fernandes Macedo 2006-10-31 07:36:02 EST
Created attachment 139846 [details]
Xorg log
Comment 2 Pedro Fernandes Macedo 2006-10-31 07:39:30 EST
Associated kernel messages from right before and right after the crash:

Oct 31 09:04:41 pedro ntpd[2020]: synchronized to 195.224.39.103, stratum 2
Oct 31 09:06:49 pedro kernel: mtrr: no more MTRRs available
Oct 31 09:06:49 pedro last message repeated 2 times
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x8000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x2000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: base(0xf2000000) is not aligned on a
size(0x5000000) boundary
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x8000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x2000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: base(0xf2000000) is not aligned on a
size(0x5000000) boundary
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x8000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: 0xf0000000,0x2000000 overlaps existing
0xf0000000,0x800000
Oct 31 09:06:49 pedro kernel: mtrr: base(0xf2000000) is not aligned on a
size(0x5000000) boundary
Oct 31 09:06:49 pedro kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Oct 31 09:06:49 pedro kernel: agpgart: Putting AGP V2 device at 0000:00:00.0
into 1x mode
Oct 31 09:06:49 pedro kernel: agpgart: Putting AGP V2 device at 0000:01:00.0
into 1x mode
Oct 31 09:06:53 pedro gconfd (pedro-21232): SIGHUP received, reloading all databases
Oct 31 09:06:54 pedro gconfd (pedro-21232): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Oct 31 09:06:54 pedro gconfd (pedro-21232): Resolved address
"xml:readwrite:/home/pedro/.gconf" to a writable configuration source at position 1
Oct 31 09:06:54 pedro gconfd (pedro-21232): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Oct 31 09:06:54 pedro gconfd (pedro-21232): GConf server is not in use, shutting
down.
Oct 31 09:06:54 pedro gconfd (pedro-21232): Exiting
Oct 31 09:12:38 pedro gconfd (pedro-8966): starting (version 2.14.0), pid 8966
user 'pedro'

lspci: 

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 81)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio
Controller (rev 50)
00:0e.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
01:00.0 VGA compatible controller: S3 Inc. ProSavage KM133 (rev 03)


details of the vga card:

01:00.0 VGA compatible controller: S3 Inc. ProSavage KM133 (rev 03) (prog-if 00
[VGA])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8041
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 11
        Memory at ef000000 (32-bit, non-prefetchable) [size=512K]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at efff0000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [80] AGP version 2.0

Comment 3 Pedro Fernandes Macedo 2006-12-04 18:10:22 EST
Since the report, I kept having this issue and all the times it happened when I
was using vncviewer. To be more precise, most crashes happened when I was doing
something else and restored the vncviewer window. System has been kept updated
and the issue still happens.
Comment 4 Matěj Cepl 2006-12-28 13:09:41 EST
Thanks for the bug report and the information attached, and I am sorry for
replying only now.

Can I ask also for your X server config file (/etc/X11/xorg.conf) attached to
the bug report as individual uncompressed file attachment using the bugzilla
file attachment link below, please?

Also I am concerned about possible problems caused by your previous
configuration from FC5 (was the system upgraded from FC5 or did you wipe out
content of your hard drive before installing FC6?). Could you please also try to
run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your
display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt
as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Pedro Fernandes Macedo 2006-12-29 06:01:34 EST
Created attachment 144530 [details]
xorg.conf
Comment 6 Pedro Fernandes Macedo 2006-12-29 06:02:02 EST
Created attachment 144531 [details]
Xorg log running without xorg.conf
Comment 7 Pedro Fernandes Macedo 2006-12-29 06:06:30 EST
This was a install from scratch, since I had been bitten by the upgrade through
dvd bug and also wanted to change my partitions.

The only file restored from backup was this xorg.conf , because right after
install, the detected resolution was too low (it seems like xorg update after
release improved the resolution, since I`m running without the xorg.conf and I
am getting a higher resolution).
Comment 8 Matěj Cepl 2006-12-29 09:05:05 EST
Try system-config-display (from the package of the same name) to configure your
resolution and stuff properly.
Comment 9 Pedro Fernandes Macedo 2007-01-19 13:50:40 EST
Just to add, since the removal of xorg.conf, the system didnt crash. 
Also, I"ve been using the xorg.conf generated by s-c-d , using the generic
1024x768 monitor definition (the philips 105E monitor wasnt recognized).
Comment 10 Adam Jackson 2007-01-29 19:27:37 EST
2: /usr/lib/xorg/modules/libxaa.so(XAAMoveDWORDS+0x40) [0x36d550]
3: /usr/lib/xorg/modules/libxaa.so(XAAWritePixmap+0x192) [0x36da22]
4: /usr/lib/xorg/modules/libxaa.so(XAADoImageWrite+0xfa) [0x3602ba]

Yikes, that's scary.
Comment 11 Pedro Fernandes Macedo 2007-06-23 13:04:48 EDT
Just a very late follow up. The issue disappeared completely after updates. I
couldnt find the exact update that fixed it though... Also, I"ve since upgraded
to Fedora 7 and havent faced this problem, so I guess we're safe to close this.
Comment 12 Adam Jackson 2007-06-27 09:43:53 EDT
Marking as WORKSFORME as per comment #11.  If this issue reoccurs for you,
please reopen this bug.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.