Bug 213275 - segfaulting firefox makes me sad.
segfaulting firefox makes me sad.
Status: CLOSED DUPLICATE of bug 208240
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 10:41 EST by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 11:25:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-10-31 10:41:17 EST
I filed some expenses with a crappy webform, left my cube to walk to a printer,
and when I came back, it had gone bang :-(

Program terminated with signal 11, Segmentation fault.
#0  0x000000323700dcbd in raise () from /lib64/libpthread.so.0
(gdb) bt
#0  0x000000323700dcbd in raise () from /lib64/libpthread.so.0
#1  0x0000000000410917 in nsProfileLock::FatalSignalHandler (signo=11) at
nsProfileLock.cpp:206
#2  <signal handler called>
#3  0x000000323a00f6d4 in FcCharSetDestroy () from /usr/lib64/libfontconfig.so.1
#4  0x00002aaab51aade5 in ~nsFontMetricsPS (this=0x2a9e4e0) at
nsFontMetricsPS.cpp:111
#5  0x00002aaab51aab32 in nsFontMetricsPS::Release (this=0x2aaaae5ecd00) at
nsFontMetricsPS.cpp:135
#6  0x00002aaaaf15c855 in nsFontCache::Flush (this=<value optimized out>) at
nsDeviceContext.cpp:715
#7  0x00002aaaaf15c90c in ~nsFontCache (this=0x2aaaae5ecd00) at
nsDeviceContext.cpp:580
#8  0x00002aaab51a8633 in ~nsFontCachePS (this=0x2aaaae5ecd00) at
nsDeviceContextPS.cpp:547
#9  0x00002aaaaf15c282 in ~DeviceContextImpl (this=0x2ace530) at
nsDeviceContext.cpp:88
#10 0x00002aaab51a7c80 in ~nsDeviceContextPS (this=0x2ace530) at
nsDeviceContextPS.cpp:134
#11 0x00002aaaaf15ca04 in DeviceContextImpl::Release (this=0x2aaaae5ecd00) at
nsDeviceContext.cpp:54
#12 0x00002aaaaeae5635 in ~nsPrintData (this=0x2a40a60) at nsPrintData.cpp:159
#13 0x00002aaaaeae2413 in nsPrintEngine::Destroy (this=0x21e7ac0) at
nsPrintEngine.cpp:283
#14 0x00002aaaaea09df5 in DocumentViewerImpl::OnDonePrinting (this=0x1614720) at
nsDocumentViewer.cpp:4141
#15 0x000000324ae722ed in PL_HandleEvent (self=0x2aaaae5ecd00) at plevent.c:688
#16 0x000000324ae724ff in PL_ProcessPendingEvents (self=0x721960) at plevent.c:623
#17 0x000000324ae737a1 in nsEventQueueImpl::ProcessPendingEvents (this=0x7218e0)
at nsEventQueue.cpp:417
#18 0x00002aaab41f228a in event_processor_callback (source=<value optimized
out>, condition=25069088, data=0x2aaaae5ecd00) at nsAppShell.cpp:67
#19 0x000000323842cf44 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x000000323842fd7d in g_main_context_check () from /lib64/libglib-2.0.so.0
#21 0x000000323843008a in g_main_loop_run () from /lib64/libglib-2.0.so.0
#22 0x000000323c52abf3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#23 0x00002aaab41f266e in nsAppShell::Run (this=0xa7f7c0) at nsAppShell.cpp:139
#24 0x00002aaab38a726a in nsAppStartup::Run (this=0xa7f740) at nsAppStartup.cpp:150
#25 0x0000000000408284 in XRE_main (argc=<value optimized out>, argv=<value
optimized out>, aAppData=<value optimized out>) at nsAppRunner.cpp:2374
#26 0x000000323641da44 in __libc_start_main () from /lib64/libc.so.6
#27 0x0000000000403939 in _start ()
Comment 1 Christopher Aillon 2006-10-31 11:25:50 EST
I just submitted 1.5.0.7-8 to FC6, but this fix is in rawhide already for the
pango case.  Will be fixed by 1.5.0.8 for non-pango case.

*** This bug has been marked as a duplicate of 208240 ***

Note You need to log in before you can comment on or make changes to this bug.