Bug 213305 - RFE: don't clear screen on login
RFE: don't clear screen on login
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 13:46 EST by Bill Nottingham
Modified: 2014-03-16 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 10:21:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-10-31 13:46:46 EST
One of the 'features' that kdm has (although it could just be by accident) is
that it doesn't clear the screen after logging in.

What this means is that if your *dm background is the same as your desktop
background, it does not flash and stays constant while the desktop is brought up
- this is a nice effect.
Comment 1 Ray Strode [halfline] 2007-04-02 10:21:06 EDT
Well, I think part of the problem is the themed greeter paints it's background
on a full screen window instead of the root window.

Since the theme format doesn't have the concept of "setting a background", but
instead has the primitive "show a full screen image, and then show other things
on top of it", it's not clear what the right way to go is.  We could

1) If an image is full screen set it as the root window background, too
2) add a new "background" primitive to the greeter and always set it as the root
window background
3) make the canvas window track the root window by default and set the
background outside of the theme before starting the greeter
4) switch to using the plain greeter by default (and making it more themable)
5) write a new themed greeter

1 is the easiest short term hack, but I think 4 is probably the right way to go
long term.  We could get a lot of themability, I think, by shipping a custom
gtkrc file and glade file.

Anyway, we're not going to tackle this for FC7, so I'm going to close this out
to get my bug count down to a manageable level.

Note You need to log in before you can comment on or make changes to this bug.