Bug 213308 - Can't read directories with many files+directories
Summary: Can't read directories with many files+directories
Status: CLOSED DUPLICATE of bug 211070
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-31 18:58 UTC by Walkie
Modified: 2015-01-04 22:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 22:28:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walkie 2006-10-31 18:58:15 UTC
Description of problem:
ls returns
ls: reading directory .: Invalid argument
on cifs mounted volume on directories with many files+directories (tested 105
number is ok, more gets error)
and orter methods to stat that directory also non-funcctionsl

Version-Release number of selected component (if applicable):
samba 3.0.23c-2

How reproducible:
server uses FC5 samba3.0.21b-2 client is FC6 samba 3.0.23c-2

Steps to Reproduce:
1. mount share with mount.cifs
2. find a directory with 105+ files on mounted volume
3. try to ls directory
  
Actual results:
ls returns
ls: reading directory .: Invalid argument


Expected results:
directory listing

Additional info:
when client was FC5 samba 3.0.23c-2 everything works fine

Comment 1 Jay Fenlason 2006-10-31 19:01:21 UTC
When using the kernel CIFS module, anything that happens after the mount 
succeeds is entirely in the kernel.  I'm redirecting this bug to the correct 
component. 

Comment 2 Dave Jones 2006-10-31 22:28:05 UTC

*** This bug has been marked as a duplicate of 211070 ***


Note You need to log in before you can comment on or make changes to this bug.