Bug 213331 - Flicker on vt consoles after switching back - unreadable
Flicker on vt consoles after switching back - unreadable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 16:09 EST by John Floyd
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 07:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (863 bytes, text/plain)
2006-12-27 15:22 EST, Leo
no flags Details
Xorg.0.log (85.85 KB, text/plain)
2006-12-27 15:25 EST, Leo
no flags Details
xorg log by starting X without xorg.conf (105.63 KB, text/plain)
2006-12-27 15:31 EST, Leo
no flags Details

  None (edit)
Description John Floyd 2006-10-31 16:09:19 EST
Description of problem:
VT Console flicker and on console on shutdown.  It is Unreadable.

Version-Release number of selected component (if applicable):
1.6.5-9.fc6

How reproducible:

Install/upgrade existing Xorg system from working FC5. 

XWindows up and running.  Do a console switch from X.  All vt consoles flicker
so much that you cant read the screen.  Also same problem on shutdown when
displaying shutdown process on console after X has been killed.

Steps to Reproduce:
1.  Not necessary - always there.
2.
3.
  
Actual results:


Expected results:

Clean readable console.

Additional info:

X config was auto genreated from X. 

Was upgrade from FC5 but X screen was corrupted (shifted down) that was why I
reconfigured using X.

FC5 was running perfectly.
Comment 1 Leo 2006-12-18 17:19:05 EST
I upgrade to FC6 by a fresh install. I can confirm this bug still exists when
using the intel modesetting driver.

Particularly when you enable framebuffer, for example, I tried passing vga=0x318
to the kernel and after booting, I can't read any characters in the console, the
console is covered by residual images.

Is there debugging going on to fix this bug? Or is there a update planned?

Thank you.
Comment 2 Matěj Cepl 2006-12-27 14:57:41 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Leo 2006-12-27 15:22:14 EST
Created attachment 144416 [details]
xorg.conf

My current xorg config file
Comment 4 Leo 2006-12-27 15:25:26 EST
Created attachment 144417 [details]
Xorg.0.log

Xorg log
Comment 5 Leo 2006-12-27 15:31:35 EST
Created attachment 144418 [details]
xorg log by starting X without xorg.conf

The corresponding xorg.conf is an empty file.
Comment 6 Matěj Cepl 2007-12-10 04:22:02 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 7 John Floyd 2007-12-11 16:04:03 EST
Problem continued on FC7.

Just recently (last week) updated to running FC8 with intel driver, with no
problems.

Closure would be reasonable.

Thanks

Note You need to log in before you can comment on or make changes to this bug.