Bug 213366 - Anaconda hangs on installation of glibc-common-2.5-3.i386 package for 128MB RAM system
Anaconda hangs on installation of glibc-common-2.5-3.i386 package for 128MB R...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 00:17 EST by Jason Warnes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 10:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Warnes 2006-11-01 00:17:53 EST
Description of problem:
I'm trying to install FC6 on an old piece of hardware.  Here are the specs (try
not to laugh too hard, it's being used as a VPN endpoint, firewall and router
for a small site I support),

	Pentium II @ 350Mhz
	128MB RAM
	4.2GB HD
	Intel PRO/100S dual-port network adapter

I'm installing this system using a PXE server and the source files are coming
off a web server.  It's the same setup I've used for countless other version of
Fedora and RHEL installations.

The problem I'm having is that the kickstart script I have for the installation
is hanging on the glibc-common-2.5-3.i386 package.  The systems downloads the
package okay and the "Status" bar fills to 100% making me think that the package
is trying to install.  But as soon as the bar hit 100% the install seems to
hang.  So I tried the installation using the PXE server without the kickstart
script and the install hangs in the same place.  This time I switched to the
second virtual console
(Alt-F2) and ran top to see what was running.  Anaconda was using 99% of the CPU.

To further complicate things the same kickstart script works on a newer piece of
hardware.  But I know this low-end hardware is good because it runs my FC5
kickstart script no problem.


Version-Release number of selected component (if applicable):
Fedora Core 6, anaconda 11.1.1.3-1 I think, but I can't really tell from the
install screen.

How reproducible:
Very reproducible.  

Steps to Reproduce:
Using the above mentioned hardware,
1. Boot the PC using an Etherboot v5.3.15 boot disk (because the system doesn't
have onboard PXE capabilities).
2. From my PXE menu, I select my Fedora Core 6 selection to start the FC6
installation.
3. The installation base images come from my Fedora Core 3 HTTP server (same
server as the PXE server).
4. The installation starts and I delete all the volumes and create separate
partitions for each /boot, swap and / (root) filesystems.
5. I deselect all the packages, and choose the custom installation to deselect
everything else.
6. Once the installation starts it hangs on the glibc-common-2.5-3.i386 package.
 As I mentioned above the Status bar fills to 100% complete and then nothing
further happens.
  
Actual results:
Anaconda hangs and consumes 99% of the CPU. 

Expected results:
Package to install and the installation to complete.

Additional info:
I've let the system sit there over night for 16 hours and it was in the same
place as when I left it.

I've just lately added another 128MB of RAM to the system and the installation
completes.  But the system requirements listed for FC6 mention that text mode
installations can run on 128MB of RAM (which is what I was hoping for).

Is there anyway that the installation can run on a 128MB RAM system?
Comment 1 Jeremy Katz 2006-11-06 10:13:54 EST
Unfortunately, I think we're just at too many packages (and thus, too high need
of memory) for 128 meg systems.  NFS _may_ work slightly better than FTP/HTTP
Comment 2 Martin Andersson 2007-02-25 05:15:41 EST
I installed on a Compaq Armada M300 (PII  300MHz Mobile) with 128MB memory,
using minimal installation - everything optional stripped away. No X obviously.

Same hangups as described above when trying anything else

Note You need to log in before you can comment on or make changes to this bug.