Bug 213424 - Marvell PATA not supported
Marvell PATA not supported
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 08:49 EST by Nerijus Baliūnas
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-15 19:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2006-11-01 08:49:30 EST
Marvell PATA controller (88SE6101, PCI ID: 11ab:6101) is not supported by kernel.
This controller is present in Intel motherboards based on P965/Q965/G965 chipsets.
There is a patch for 2.6.18 kernel published at LKML:
http://lkml.org/lkml/2006/10/16/157
Comment 1 filippo david 2006-11-05 08:09:31 EST
I have an Intel DG965WH motherboard with this controller; booting with
"all-generic-ide" and "irqpoll" options let me use my PATA cdrom, but every once
in a while i get this message in dmesg output:
"hdi: cdrom_pc_intr: The drive appears confused (ireason = 0x01). Trying to
recover by ending request."
Comment 2 Davide Bolcioni 2007-02-08 15:11:36 EST
I also had some success by adding ide2=0x1018 to the kernel command line, 
after setting the BIOS to use AHCI for the SATA drives. The latter turn up as 
sda and sdb, while the CDROM turns up as hde. I also used all-generic-ide to 
find out the base address above; note that ide0=0x1018 resulted in "disabling 
interrupt #169" with the kernel boot processing stopping dead there.
Comment 3 Davide Bolcioni 2007-02-08 15:59:49 EST
The above was using a i686 kernel, the address using an X86_64 ended up being 
different; it is probably wiser to use "all-generic-ide" instead. However, I 
burned a Fedora DVD just fine (from nautilus) with the above setting.
Comment 4 Nerijus Baliūnas 2007-02-08 20:32:16 EST
pata_marvell first appears in 2.6.20. I was able to compile pata_marvell.c from
2.6.20 under 2.6.19 without problems, and resulting pata_marvell.ko works ok.
Comment 5 Nerijus Baliūnas 2007-03-16 17:11:26 EDT
Unfortunately CONFIG_PATA_MARVELL is not set in 2.6.20-1.2925.fc6. Please
include it in the next kernel build, as without it CDs are not working in 965
chipsets.
Comment 6 Justin Moore 2007-03-16 23:00:06 EDT
I just wanted to second Nerijus's request.  I have a Intel DG965WH motherboard
and have been waiting for for this chipset to be supported in Fedora; the fix
has been in the kernel since the 2.6.20 release in late Jan/early Feb but hasn't
shown up yet.  Please include it in the next release.
Comment 7 Justin Moore 2007-04-01 21:52:57 EDT
Follow-up:

I grabbed the source RPM for kernel-2.6.20-1.2933.fc6.x86_64, enabled
CONFIG_PATA_MARVELL in the .config file as a module, compiled it, and loaded the
pata_marvell.ko driver.  It works just fine on my DG965WH motherboard; I was
able to see my DVD drive and successfully play a test DVD.
Comment 8 Chuck Ebbert 2007-04-02 10:03:42 EDT
pata_marvell will be enabled in the next release.
Comment 9 Nerijus Baliūnas 2007-04-15 19:41:26 EDT
It is enabled in 2.6.20-1.2944.fc6 and works ok, thanks!

Note You need to log in before you can comment on or make changes to this bug.