Bug 213466 - Amarok should obsolete amarok-extras-nonfree < 1.4.4
Amarok should obsolete amarok-extras-nonfree < 1.4.4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 11:16 EST by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 11:49:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2006-11-01 11:16:43 EST
Description of problem:
In order to support clean upgrade paths, either the amarok in Extras should 
obsolete amarok-extras-nonfree < 1.4.4 or the new xine-lib-extras-nonfree in 
Livna will have to provide and obsolete amarok-extras-nonfree.

The description should also be fixed not to say that the Xine engine is 
disabled by default anymore. ;-)

Version-Release number of selected component (if applicable):
amarok-1.4.4-1.fc6
Comment 1 Aurelien Bompard 2006-11-01 11:33:09 EST
I'm thinking of doing it another way around. I'm waiting for
xine-lib-extras-nonfree to be accepted there, and then I'll fix
amarok-extras-nonfree to be just a dummy package requiring xine-lib-extras-nonfree.
The reason is that there may be extras nonfree plugins for amarok in the future
which are outside of the scope of xine-lib (for example : mp4 tagging). So I
want to keep amarok-extras-nonfree around.

But first, xine-lib-extras-nonfree must be accepted in Livna.
Comment 2 Kevin Kofler 2006-11-01 11:35:11 EST
Makes sense. The description still ought to be fixed though. ;-)
Comment 3 Aurelien Bompard 2006-11-01 11:47:44 EST
Fixed in CVS :)
Comment 4 Kevin Kofler 2006-11-01 11:49:35 EST
Then everything has been answered and the only real bug has been fixed.

Note You need to log in before you can comment on or make changes to this bug.