Bug 21350 - sort -t'\\' fails
Summary: sort -t'\\' fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-26 16:49 UTC by Felix Lee
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-26 16:49:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felix Lee 2000-11-26 16:49:25 UTC
$ sort -t'\\'
sort: unrecognized option `-\'

Unix98 doesn't require this to work, but it works on Solaris, and it's an
odd anomaly.  sort -t'x' works as expected.

Comment 1 Bernhard Rosenkraenzer 2001-01-12 15:39:45 UTC
Are you sure this works in Solaris? Looks incorrect to me...

It's 

sort -t'\'

or

sort -t"\\"

or is sort -t'\\' supposed to do anything else?


Comment 2 Felix Lee 2001-01-13 01:46:38 UTC
ah, you're right.  my mistake.

it happens to work on solaris because solaris's sort ignores extra junk after
the -t option.  'sort -tfoo' is equivalent to 'sort -tf'.

thanks.



Note You need to log in before you can comment on or make changes to this bug.