Bug 213539 - conflicting types for dm_create in kernel headers
conflicting types for dm_create in kernel headers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 16:49 EST by Sampo Soini
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.18-1.2849
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 14:57:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sampo Soini 2006-11-01 16:49:53 EST
Description of problem:
Truecrypt does not compile because of conflicting declarations
of dm_create function in kernel headers.
Here's the error message from compilation:
In file included from /usr/local/src/truecrypt-4.2a/Linux/Kernel/Dm-target.c:18:
/usr/src/kernels/2.6.18-1.2798.fc6-i686/drivers/md/dm.h:48: error: conflicting
types for ‘dm_create’
include/linux/device-mapper.h:144: error: previous declaration of ‘dm_create’
was here


Version-Release number of selected component (if applicable):
kernel-devel-2.6.18-1.2798.fc6

How reproducible:
Only tried this on one computer.

Steps to Reproduce:
1. Try to compile the truecrypt sources
(http://www.truecrypt.org/downloads/truecrypt-4.2a-source-code.tar.gz)
2.
3.
  
Actual results:
Should compile

Expected results:
Won't compile

Additional info:

Note You need to log in before you can comment on or make changes to this bug.