Bug 213546 - Memory protection failure while playing game that uses perl-Tk (fixed by downloading perl-Tk from atrpms repository)
Memory protection failure while playing game that uses perl-Tk (fixed by down...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Tk (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 17:06 EST by Paul Osmialowski
Modified: 2008-01-11 17:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 804.028-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:18:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Osmialowski 2006-11-01 17:06:49 EST
Description of problem:
Memory protection failure while playing game that uses perl-Tk

Version-Release number of selected component (if applicable):
perl-Tk-804.027-10.fc6

How reproducible:
Always

Steps to Reproduce:
1. download http://isoid.king.net.pl/tk-horace-20060126.tar.gz, unpack and run
2. finish level 1
3.
  
Actual results:
while changing to level 2, memory protection failure will crash whole game. It
has never happend before while tested on many other unixes including cygwin
enwironment!

Expected results:
game should change to level 2

Additional info:
there is actually another perl-Tk package on atrpms repository
(perl-Tk-804.027-12.fc6.at), this one does not crash the game, additonally
atrpms provides one more rpm for perl-Tk with TableMatrix widget
(perl-Tk-TableMatrix-1.2-17.fc6.at).
Comment 1 Paul Osmialowski 2007-07-07 10:16:46 EDT
The same problem with F7 and the same solution: download
http://dl.atrpms.net/all/perl-Tk-804.027-12.fc6.at.i386.rpm from atrpms (there's
no F7 version there, but this one is still newer that the one shipped with F7)
and perl-Tk-TableMatrix-1.2-17.fc7.i386.rpm (version dedicated for F7 this time)
from atrpms. This solves mentioned bug for good.
Comment 2 Andreas Bierfert 2008-01-03 18:50:45 EST
I wonder if this is still valid. Could you please try with the version in F-8
updates testing (Should also hit stable with the next push)?

http://koji.fedoraproject.org/koji/search?terms=perl-Tk-804.028-1.fc8&type=build&match=glob
Comment 3 Paul Osmialowski 2008-01-04 09:57:27 EST
Yup, still it is the problem. It is caused by messageBox call which opens small
window with given message. When user press OK button, process is killed by
SIGSEGV. How come FC6 atrpms's implementation does not have the issue?
Comment 4 Andreas Bierfert 2008-01-04 11:34:14 EST
I have no clue. Sadly. I just tried here with the described game and
perl-Tk-804.028-1.fc8 and I am not able to reproduce the issue. Can you provide
any further information like a backtrace e.g.?
Comment 5 Andreas Bierfert 2008-01-04 19:00:02 EST
I have just fixed another SIGSEGV in perl-Tk. Could you try with -2

rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=30137
f8: http://koji.fedoraproject.org/koji/buildinfo?buildID=30136
f7: http://koji.fedoraproject.org/koji/buildinfo?buildID=30138
Comment 6 Paul Osmialowski 2008-01-05 05:09:04 EST
I've updated to version -2 and it started to work fine. Now messageBox does not
cause SIGSEGV.
Comment 7 Andreas Bierfert 2008-01-05 05:26:48 EST
Great thanks for the reply.
Comment 8 Fedora Update System 2008-01-06 20:20:44 EST
perl-Tk-804.028-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'
Comment 9 Fedora Update System 2008-01-06 20:29:39 EST
perl-Tk-804.028-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'
Comment 10 Fedora Update System 2008-01-11 17:15:58 EST
perl-Tk-804.028-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-01-11 17:18:54 EST
perl-Tk-804.028-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.