Bug 213564 - spec bug: filesystemmonitor.schema no longer included
spec bug: filesystemmonitor.schema no longer included
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 18:54 EST by Michel Alexandre Salim
Modified: 2007-12-27 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.12.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 18:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed libdir patch (706 bytes, patch)
2006-11-01 20:02 EST, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2006-11-01 18:54:36 EST
Description of problem:
Banshee used to include filesystemmonitor.schema, and the spec file still tries
to install it in %post. Since the file is no longer there it throws an error 

I/O warning : failed to load external entity
"/etc/gconf/schemas/filesystemmonitor.schemas"
Failed to open `/etc/gconf/schemas/filesystemmonitor.schemas': No such file or
directory

Version-Release number of selected component (if applicable):
0.10.12-4

How reproducible:
Always

Steps to Reproduce:
1. Install banshee
  
Actual results:
Error as above

Expected results:
No error

Additional info:
Is an update to 0.11.2 planned? I tried updating it myself but encounters a
problem on startup, claiming it could not load avahi.
Comment 1 Michel Alexandre Salim 2006-11-01 20:02:31 EST
Created attachment 140061 [details]
Fixed libdir patch
Comment 2 Michel Alexandre Salim 2006-11-01 20:05:48 EST
The new test for assemblies introduced by the mono-libdir patch to configure is
incorrect: with > 1 test expression, the form used should be

if ! [ exp1 -o exp2 ]

instead of 

if test ! \( exp1 -o exp2 \)

This does not actually change the build result, since the test failed to run and
thus did not abort the configure process (had it run it would have succeeded
anyway, since the BuildRequires ensure that the .dlls would be present)
Comment 3 Chris Weyl 2007-05-02 19:38:57 EDT
Schema import bug still present in latest FC-6 release.
Comment 4 Christopher Aillon 2007-12-27 18:27:47 EST
This was fixed in F-7 and later with:

* Fri Mar 30 2007 Christopher Aillon <caillon@redhat.com> - 0.12.0-5
- Fix up schema installs

Note You need to log in before you can comment on or make changes to this bug.