Bug 213613 - grouplist not giving output for debuglevel 0 or 1
grouplist not giving output for debuglevel 0 or 1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 05:37 EST by Tomasz Kepczynski
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 15:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2006-11-02 05:37:45 EST
Description of problem:
I tried to get grouplist as below:
$ sudo yum -d 0 grouplist
and yum did not output a thing. The same problem with:
$ sudo yum -d 1 grouplist
This is probably due to usage of debig output functions instead
normal output functions.

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5.noarch

How reproducible:
always

Actual results:
No output.

Expected results:
List of groups.
Comment 1 Jeremy Katz 2007-04-25 14:44:01 EDT
-d0 and -d1 only show errors and warnings, respectively.  Nothing which is just
info (including things like grouplists)
Comment 2 Tomasz Kepczynski 2007-04-26 00:45:23 EDT
1. I do not agree. When program's normal behaviour is to produce
some output, it should do so without turning debugging on. And
output in this case is implied by command line arguments.
2. When closing as NOTABUG you should at least provide some reasoning
why it is not considered a bug.
3. This also does not work on FC6, updating version and reopening.
Comment 3 Tomasz Kepczynski 2007-04-26 00:49:22 EDT
Sorry for #2 above, I missed your explanation.
Anyway - I may want to take output from yom for further processing
and I want to see ONLY what I requested. -d0 and -d1 show nothing, 
-d2 adds some irrelevant info like below:
Loading "fedorakmod" plugin
Loading "installonlyn" plugin
Loading "allowdowngrade" plugin
Loading "protectbase" plugin
Loading "skip-broken" plugin
Loading "priorities" plugin
Loading "kernel-module" plugin
Loading "downloadonly" plugin
Setting up Group Process
Setting up repositories
Installed Groups:
   Office/Productivity
...
Which is out of interest in such a case.
As I mentioned in initial report - normal output should not
go through debug facilities!

Note You need to log in before you can comment on or make changes to this bug.