Bug 21362 - RH 7 compiler rejects fpos_t assignments (RH6.2 worked)
RH 7 compiler rejects fpos_t assignments (RH6.2 worked)
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-11-26 16:54 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-11-26 16:54:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-26 16:54:23 EST
In Red Hat 6.2, I could declare & assign fpos_t as follows:

fpos_t loc;
loc = 0;

In Red Hat 7, the same code generates a compiler error:

"incompatible types in assignment"

Please help - This was an experiment to convince my bosses to switch from 
NT to Linux.
Comment 1 Jakub Jelinek 2000-11-27 02:20:40 EST
fpos_t is no longer a scalar type, there is nothing in the standards
which demand this to be a scalar btw. This is so that proper wide
stream support could be added.
As I have no idea what you wanted to achieve, I cannot suggest
what you should do instead, but one hint could be that fpos_t used
to be the same as off_t (resp. off64_t for fpos64_t), so you could
maybe use those types instead.
This is not related to gcc at all, the change happened in glibc

Note You need to log in before you can comment on or make changes to this bug.