Bug 213620 - DomVTi cannot work properly and Domain0 becomes hang
DomVTi cannot work properly and Domain0 becomes hang
Status: CLOSED DUPLICATE of bug 213611
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
ia64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 06:00 EST by Watanabe Takehiko
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 06:46:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Watanabe Takehiko 2006-11-02 06:00:03 EST
Description of problem:
I'm using Milestone 7 on our PRIMEQUEST 580 and 520. I attmpted repeating a
process of creating VTi domain with its console and then shutdown it in
nographic mode. 
The first process succeed but the second process and later are failed with the
following message.

 xenconsole: Could not read tty from store: No such file or directory

And Domain0 sometimes became hang in this process. 

Version-Release number of selected component (if applicable):

xen-libs-3.0.3-2.el5
kernel-xen-2.6.18-1.2732.el5
xen-3.0.3-2.el5


How reproducible:
sometimes

Steps to Reproduce:
1.xm create -c <config>
2.xm shutdown <domain>
3.xm create -c <config>
  
Actual results:
After finished the first process, the following message was displayed and the
domian cannot create its console.

 xenconsole: Could not read tty from store: No such file or directory

Domain0 sometimes becomes hang in this process. 

Expected results:
The process is repeated with no problem.

Additional info:
Here is my config file for reference.

----------------------------------------------------
#!/usr/bin/python

kernel = "/boot/Flash.fd"
builder = "hvm"
memory = 512
vcpus = 2
name = "vm1"
disk = [ 'file:/xen/xen-test/image/rhel4_vti1.img,ioemu:hda,w' ]
device_model = "/usr/lib/xen/bin/qemu-dm"
memmap = "/usr/lib/xen/boot/mem-map.sxp"
sdl = 0
vnc = 0
vncviewer = 0
nographic = 1
serial = "pty"
----------------------------------------------------
Comment 1 Stephen Tweedie 2006-11-02 06:46:27 EST

*** This bug has been marked as a duplicate of 213611 ***

Note You need to log in before you can comment on or make changes to this bug.