Bug 21364 - Text Mode Setup gives wrong screen resolution
Text Mode Setup gives wrong screen resolution
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-26 18:03 EST by drummond
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 14:34:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drummond 2000-11-26 18:03:21 EST
When installing RedHat 7.0 on a laptop (Gateway Solo 5150), with a
1024*768 generic LCD screen, the X configuration is set incorrectly,
giving the wrong screen resolution (dpi). This causes applications using
scaleable fonts to fail completely.

The program xdpyinfo returns 10*7 dots per inch. It should be 90*90 -
or even 100*100, depending on the actual screen size. At 10*7, programs
like Lyx, Ghostview, and certain KDE2.0 system programs will not be able
to display any readable screen fonts!

This problem did not occur in RH6.0, and is presumably a bug in the
new X86 installer. Another problem is that when I enter the name of the
component into Bugzilla - which is Text Mode Setup Utility 1.5 - Bugzilla
refuses to accept this name.
Comment 1 Preston Brown 2001-01-29 14:34:47 EST
Please cut-and-paste your XF86Config-4 file.  What display hardware is this
(Graphics chipset)?
Comment 2 Preston Brown 2001-02-12 12:49:44 EST
closed due to lack of additional feedback.

Sounds like a hardware problem -- XFree 4 and higher trust the hardware to
return their correct physical dimensions via DDC so that proper DPI can be set.
Comment 3 drummond 2001-05-01 00:22:31 EDT
This bug may be a hardware problem, but the final result on my laptop
is an apparent screen resolution of 10 dpi, when it should be 100. An
obvious resolution would be if Xconfigurator simply requests the installer
to confirm or correct the resolution.

When this problem occurs - which is still present in REDHAT 7.1 - you
will break the KDE login, and find the buttons unreadable, as well
as the installed fonts. Other broken applications include ghostview,
which also uses the dpi information.

A manual fix for those people who find this problem, is to manually edit
the X command where X is started, inserting the command X -dpi 100x100
in the last line of the system configurations file /etc/X11/xdm/Xservers!
For gdm you have to edit the file:

   /etc/X11/gdm/gdm.conf

and modify the 2nd last line to say:

   0=/usr/bin/X11/X -dpi 100x100

or whatever dpi values are appropriate.

Comment 4 drummond 2001-05-01 00:37:55 EDT
My laptop video chip is the Neomagic MagicMedia 256AV (NMG5) with 2.5MB Sdram,
and the screen-size is 14.1''.

Note You need to log in before you can comment on or make changes to this bug.