Bug 213645 - No Javaprinting since cups 1.2.2
No Javaprinting since cups 1.2.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-11-02 08:23 EST by Sven Schmidt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 12:10:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cups error log (53.87 KB, application/octet-stream)
2006-11-06 09:03 EST, Sven Schmidt
no flags Details

  None (edit)
Description Sven Schmidt 2006-11-02 08:23:20 EST
Description of problem:

Since upgrading cups to 1.2.2 on Fedora Core 5 the printers don't accepting jobs
from Java.
In Fedora Core 6 and Cups 1.2.4-9 it's still the same.
The command "lpoptions" don't show any printers


Version-Release number of selected component (if applicable):
1.2.4-9

How reproducible:


Steps to Reproduce:
1. If the language in /etc/sysconfig/i18n is de_DE it doesn't prints.
2. If the language in /etc/sysconfig/i18n is en_EN it prints!!
3. The command lpoptions don't show any printers
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2006-11-02 08:29:12 EST
I need some more information:

1. 'lpoptions' isn't for listing printers -- try 'lpstat -s'.  What does it say?

2. How exactly are you printing?  Are you running the java program from the
command line?

3. Does printing from other applications work?  Does a test page work?
Comment 2 Sven Schmidt 2006-11-02 11:25:43 EST
1. It shows the printer, but the lpoptions command normaly shows the printers
too and additional the status (printer is accepting jobs). Can it be that
javaprinting uses this command for getting available printers?! On the other
side it is strange that the printer prints from java applications if the
language settings in i18n is english....

2. The javaprogramm runs with JavaWebStart and there were no printing-problems
until cups 1.2.2

3. Yes, printing from all other applications works and the test page works too.

Comment 3 Tim Waugh 2006-11-03 08:14:09 EST
Which implementation of Java are you using?

You can find out precisely what it's up to by running this:

strace -p 400

if 400 is the PID of the process.  I'd like to see the strace output from when
it tries to print.
Comment 4 Sven Schmidt 2006-11-03 09:59:29 EST
I've tested several versions:
Sun JRE 1.5.0_02 
and now also the newest Version Sun JRE 1.5.0_09

The strace -p shows only:
futex(0xa5839d3c, FUTEX_WAIT, 1, NULL
and when i start printing nothing happens in strace-output.


Comment 5 Tim Waugh 2006-11-03 12:55:58 EST
How about if you run 'tail -f /var/log/cups/error_log' as root while getting the
application to print?
Comment 6 Sven Schmidt 2006-11-06 06:22:13 EST
I [06/Nov/2006:12:18:32 +0100] cupsdAcceptClient: skipping getpeercon()
I [06/Nov/2006:12:18:32 +0100] cupsdAcceptClient: skipping getpeercon()
I [06/Nov/2006:12:18:32 +0100] cupsdAcceptClient: skipping getpeercon()
I [06/Nov/2006:12:18:33 +0100] cupsdAcceptClient: skipping getpeercon()
I [06/Nov/2006:12:18:34 +0100] cupsdAcceptClient: skipping getpeercon()
Comment 7 Tim Waugh 2006-11-06 07:49:12 EST
Please edit /etc/cups/cupsd.conf and change the 'LogLevel' line to read:

LogLevel debug2

Then restart CUPS:

/sbin/service cups stop
>/var/log/cups/error_log
/sbin/service cups start

Print your job and then please attach the /var/log/cups/error_log file here. 
Thanks.
Comment 8 Sven Schmidt 2006-11-06 09:03:35 EST
Created attachment 140474 [details]
Cups error log
Comment 9 Sven Schmidt 2006-11-06 09:09:34 EST
See attachment for further information
Comment 10 Tim Waugh 2006-11-06 10:57:26 EST
It never submits the job for printing.  We just get:

D [06/Nov/2006:14:54:59 +0100] CUPS-Get-Printers
D [06/Nov/2006:14:54:59 +0100] Get-Jobs ipp://localhost:631/printers/Brother
D [06/Nov/2006:14:54:59 +0100] CUPS-Get-Printers
D [06/Nov/2006:14:54:59 +0100] Get-Jobs ipp://localhost:631/printers/Brother
D [06/Nov/2006:14:54:59 +0100] CUPS-Get-Printers
D [06/Nov/2006:14:54:59 +0100] Get-Jobs ipp://localhost:631/printers/Brother
D [06/Nov/2006:14:54:59 +0100] CUPS-Get-Printers
D [06/Nov/2006:14:54:59 +0100] Get-Jobs ipp://localhost:631/printers/Brother
D [06/Nov/2006:14:55:00 +0100] CUPS-Get-Printers
D [06/Nov/2006:14:55:00 +0100] Get-Jobs ipp://localhost:631/printers/Brother

Additionally, I *have* been able to get print output from a Java web applet
running under Sun's jre1.5.0_09 package.

The 'lpoptions' is not for listing printers, and never has been.  It shows
default printer options, and is working correctly here.
Comment 11 Sven Schmidt 2006-11-06 11:42:10 EST
Did you set the language in i18n to German (de_DE)? In english i can print too.
I've "googled" for this problem and found:

In german:
http://www.fedorablog.de/archives/104-Java-druckt-nicht-mehr-auf-Fedora.html 

And another discussion at sun. The bugreport starts with an other problem but at
the middle and the bottom they tell the same problems. 
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6181488

Comment 12 Tim Waugh 2006-11-06 12:10:33 EST
Then the solution is for Sun to fix their Java implementation.  Not a Fedora bug.

For what it's worth, the behaviour seems to be as if they are parsing the output
of 'lpstat', but forgot to set LC_MESSAGES in the environment and don't
understand the translated text ('System Standardziel' instead of 'system default
destination' etc).
Comment 13 Sven Schmidt 2006-11-06 12:22:08 EST
And why it works with cups 1.2.1 ?
Comment 14 Tim Waugh 2006-11-06 12:43:30 EST
The German translation wasn't introduced until 1.2.2.

Note You need to log in before you can comment on or make changes to this bug.