Bug 213663 - Horribly slow feed view rendering
Horribly slow feed view rendering
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 09:23 EST by Stefan Plewako
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 21:23:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Plewako 2006-11-02 09:23:13 EST
Description of problem:
Lifrea start to horribly slow render feeds views and takes in this time almost
100% cpu.. it's annoying because sometimes it takes up to few minutes for each
feed/subscribtion.

Version-Release number of selected component (if applicable):
liferea-1.0.25-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Run Liferea
2. Click on any feed to read it.
  
Actual results:
It takes from 20 up to ~180 seconds with about 90% usage of cpu to display feed
content.

Expected results:
Normal performance will be restored (like from fc5's lifrea realeases would be
enough)

Additional info:
When running liferea with debug option, I see in a log something like this,
after I click some feed to read it:
$liferea --debug-verbose
[... startup initial logs ..]
(     feed.c:602:       feed_add_item)(thread 0x819e388)(time 14:59:19) : check
new item for merging: "Odometer stopped working"
(     feed.c:701:       feed_add_item)(thread 0x819e388)(time 14:59:19) : ->
item added to feed itemlist
[... many many lines like above, for evry feed entry, in every subscription ..]

don't know if this is correct, how it affect performance, but checking every
feeds entry every time I click any feed is very strange for me.
Comment 1 Stefan Plewako 2006-11-05 13:46:39 EST
Ok, I clean up ~/.lifrea/mozilla/* from an old Mozilla Suite profile (or
precisely: Seamonkey via symbolic links) (btw it would be nice, if this coluld
be posibble by default with some backup of an old profile), and customize new
Firefox profile, there is a progress - but still it is much slower than in FC5 -
this is normal?
Comment 2 Brian Pepple 2006-11-16 16:52:22 EST
Are you still experiencing this?  If you are, could you attach your opml, so I
can try to reproduce the behavior, since I can't currently.
Comment 3 Brian Pepple 2006-12-21 21:23:08 EST
Closing since unable to reproduce, and bug reported has failed to respond to
information request.

Note You need to log in before you can comment on or make changes to this bug.