Bug 213671 - Need to modify how mdadm is called in rc.sysinit
Summary: Need to modify how mdadm is called in rc.sysinit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On: 213669
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 14:37 UTC by Doug Ledford
Modified: 2014-03-17 03:03 UTC (History)
1 user (show)

Fixed In Version: 8.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 23:46:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doug Ledford 2006-11-02 14:37:07 UTC
In order to make use of version 1.0 superblocks in md raid arrays, the system
boot up process must be able to work without raid autorun capabilities.  Right
now, the section of rc.sysinit that calls mdadm won't work, but it's hidden by
raid autorun doing the work for it.  Due to lack of devices in the /dev
filesystem, the raid bringup via mdadm needs to read as mdadm -A -s --auto=yes
(or else we have to change anaconda to add an --auto= flag to each ARRAY entry
in /etc/mdadm.conf, which might be preferable, but for the sake of safety, that
should override the command line, not cause us to leave the --auto part out of
the command line).

Comment 1 Bill Nottingham 2006-11-02 16:44:21 UTC
Added in CVS, will show up in rawhide eventually.

Comment 2 Bill Nottingham 2007-04-16 23:46:53 UTC
This was fixed in 8.47-1.

Comment 3 Bill Nottingham 2007-04-16 23:47:25 UTC
This was fixed in 8.47-1.


Note You need to log in before you can comment on or make changes to this bug.