Bug 213693 - audbin can't concatenate to a >= 2GB (2GiB, really) file
Summary: audbin can't concatenate to a >= 2GB (2GiB, really) file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: laus (Show other bugs)
(Show other bugs)
Version: 3.8
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-02 16:38 UTC by Buck Huppmann
Modified: 2015-01-08 00:14 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0459
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 18:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0459 normal SHIPPED_LIVE laus bug fix update 2007-06-07 22:56:37 UTC

Description Buck Huppmann 2006-11-02 16:38:03 UTC
Description of problem:
audbin isn't compiled with -D_FILE_OFFSET_BITS=64
so it fails with EFBIG if opening a file >= 2-GiB
(for concatenation. this may the case also for
auditd in the bugzilla 125726 that somebody else
reported and that was closed without mention of
what the resolution was)

Version-Release number of selected component (if applicable):
laus-0.1-70RHEL3

How reproducible:
use audbin -C -a as your notify command in audit.conf and
generate enough audit data (excercise for the reader--or,
in our case, our users) to cause serious binmode log
churn (before logrotate cleans up)

Steps to Reproduce:
1. as described above
2.
3.
  
Actual results:
notify command fails

Expected results:
audbin appends to file without dying

Additional info:
see attached log file indicating problem

Comment 3 Steve Grubb 2007-03-21 15:33:56 UTC
Looks like an easy fix.

Comment 6 Steve Grubb 2007-03-21 17:33:11 UTC
laus-0.1-76RHEL3 has been built with what I believe to be the fix.

Comment 10 Red Hat Bugzilla 2007-06-11 18:39:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0459.html



Note You need to log in before you can comment on or make changes to this bug.