Bug 213724 - Bug expection with a Raid1 on a "HP ProLiant ML310 G3" server
Bug expection with a Raid1 on a "HP ProLiant ML310 G3" server
Status: CLOSED DUPLICATE of bug 409931
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 13:39 EST by François-Xavier Desruelles
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description François-Xavier Desruelles 2006-11-02 13:39:39 EST
Description of problem:I have a "HP ProLiant ML310 G3" with 2 hard drive of 80G.
I have a raid1 controler on my mother board.
I build a Raid1 with my 2 hard drives with the bios.
The bios recognize the raid1.
So I started to installed FC6, but just after selected the language for the
keyboard and click next.
I've got an exeption

This is some line of the exeption:
"File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext self.moveStep()
File "/usr/lib/anaconda/gui.py", line923, in nextClicked
self.anaconda.dispatch.gotoNext()
Exeption: device-mapper: reload ioctl failed: Aucun périphérique ou adresse
in nextClicked"


Version-Release number of selected component (if applicable):


How reproducible: 
Build a Raid1 with the bios on a "HP ProLiant ML310 G3" server. Try to set up
FC6, after the selection of language of keybord, an exeption appear.



Steps to Reproduce:
1.Build a Raid1 with the bios on a "HP ProLiant ML310 G3" server.
2.Select French language
3.French Keybord
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2006-11-02 14:03:35 EST
Boot with the 'nodmraid' option at the boot: prompt and report what happens.
Comment 2 François-Xavier Desruelles 2006-11-03 07:57:00 EST
(In reply to comment #1)
> Boot with the 'nodmraid' option at the boot: prompt and report what happens.

I tried before try the 'nodmraid' option, to set up with FC5.
And just after the choice of the language, I've got this warning:
"La table de partition du périférique sda est illisible. Elle doit être
initialisée pour créer de nouvelle partitions. Cette initialisation provoquera
la perte de TOUTES LES DONNEES contenues sur ce disque.

Cette opération annulera tout choix d'installation précédent précisant les
disques durs qui ne doivent pas être pris en compte.
Voulez-vous initialiser ce disque et, ce faisant, effacer TOUTES LES DONNEES ?"

Ok, it is French, I will try to explain:
"The periferic partition table is unreadable. It must be initialised to create
new partition. With this procedure you will lose all your data in this disk.
This operation will cancelled all other choice of installation made before which
specified the hard drive which dont need to use.
Do you want to initialised this disk and, lose all your data"

So I choose YES, and I could set up FC5, but after the installation, when my
server was stopping in the loading of FC5 (just after the "bluetooth->ok"
anyway, without raid I've always got this error with FC5, I dont know why.

So I tried the 'nodmraid' option and everything is OK, I could start FC6.
But the Raid1 is not working
Comment 3 François-Xavier Desruelles 2006-11-07 08:59:00 EST
I can see, I am not the only one with the problem:
http://forums.fedoraforum.org/showthread.php?p=662291#post662291

I dont understand everything, but is it a solution for the problem ? (post 17
and 18):
http://forums.fedoraforum.org/showthread.php?t=133481&page=2

Comment 4 Joel Andres Granados 2008-01-28 05:14:46 EST
Is this issue still relevant for f9?
Comment 5 Bug Zapper 2008-04-04 00:22:11 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Joel Andres Granados 2008-04-24 10:08:25 EDT
There is a bug where the dmraid stuff just blocks.  This bug has not been solved
yet and we are still working to fix it.   However there is a work around.  If
you use nodmraid, the installer will ignore/skip the dmraid stuff allowing the
install to finish.  This is a workaround and does not fix the problem.
There is a long list of bugs that are filed against this problem.  This bug is
one of them.  We have decided to close all the related nodmraid bugs and leave
just one open that will represent all of the others.  So this bug will be duped
for this reason.

*** This bug has been marked as a duplicate of 409931 ***

Note You need to log in before you can comment on or make changes to this bug.