Bug 213739 - i965 + compiz + virtual resolution = chaos
i965 + compiz + virtual resolution = chaos
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 14:29 EST by Bill Nottingham
Modified: 2014-03-16 23:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 12:26:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (61.04 KB, text/plain)
2006-11-02 14:30 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2006-11-02 14:29:18 EST
Description of problem:

i965 attached to 2405FPW. Since it's non-modesetting, it chooses to run
at 1280x1024 with a virtual of 1600x1200.

compiz is fubar.
1) the mouse pointer isn't in sync with the screen
2) scrolling down just shows black for the bottom 176 pixels
3) I can't actually scroll right to see the right 320 pixels

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-9.fc6
compiz-0.0.13-0.32.20060817git.fc6
mesa-libGL-6.5.1-8.fc6
xorg-X11-server-Xorg-1.1.1-47.fc6
Comment 1 Bill Nottingham 2006-11-02 14:30:30 EST
Created attachment 140175 [details]
X log
Comment 2 Marius Andreiana 2007-01-12 02:00:13 EST
Hi,

Could this be fixed before F7 test1?

Thanks
Comment 3 Ilya Ryabinkin 2007-02-20 09:54:13 EST
Driver info:
xorg-x11-drv-i810-1.6.5-10.fc6

$ uname -a
Linux node7 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 i686 i386
GNU/Linux

Intel motherboard with integrated graphics, Core 2 Duo E4300
Comment 4 Matěj Cepl 2007-12-10 04:22:45 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 5 Jesse Barnes 2008-01-10 16:59:29 EST
Bill, does this happen with the modesetting driver?  i810 is pretty deprecated 
so fixes are unlikely there...
Comment 6 Bill Nottingham 2008-01-10 17:18:04 EST
Hard to tell - getting the modesetting to start up with virtual res seems
tricky. (And probably pointless)
Comment 7 Jesse Barnes 2008-01-10 17:28:52 EST
Well, since i810 is deprecated, maybe this should just be wontfixed?
Comment 8 Bill Nottingham 2008-01-10 17:33:43 EST
Works for me.
Comment 9 Matěj Cepl 2008-01-11 12:26:38 EST
Cool.

Note You need to log in before you can comment on or make changes to this bug.