Bug 213744 - HP is asking Red Hat to enable XFS in RHEL 5/6 to support large filesystems
HP is asking Red Hat to enable XFS in RHEL 5/6 to support large filesystems
Status: CLOSED DUPLICATE of bug 435304
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
All Linux
medium Severity high
: rc
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
Depends On:
  Show dependency treegraph
Reported: 2006-11-02 15:26 EST by Terry Rudd
Modified: 2009-12-09 13:16 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-09 16:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Terry Rudd 2006-11-02 15:26:41 EST
Description of problem: Request for XFS File System support for >80TB file
systems on RHEL 5

Version-Release number of selected component (if applicable): Wanted in RHEL 4
U4 but more reasonably in RHEL 5

How reproducible: HP support team verified that this functionality is not
available in the latest RHEL OS release.  XFS is available with Novell/SuSE
SLES, also with Fedora Core 5 as well as other distributions and our particular
customer is going to look

Steps to Reproduce:
Actual results: No real support for >18TB filesystems

Expected results: For large enterprise machines, running very large databases,
it is possible to require 80-90TB and RHEL should support that.

Additional info:  Submitted by HP Open Source Linux Organization support
manager, Terry Rudd on behalf of our customer Maryland Procurement Office. Our
customer has a need for XFS for support of 90TB file system size on
RedHat Release 4 and future.  According to customer, the lack of XFS on RedHat
is likley a procurement prohibitor for HP systems with RedHat installed.

Per Jim Hofmeister in HP Support Services, we have had a request from 4000125069
U S MARYLAND PROCUREMENT OFFICE but are also seeing multiple requests on the
opensource.linux news group for other customers all requesting XFS for file
systems > 18TB  I have opened a call with our RedHat TAM and have been directed
to the ONE VOICE program, from which this call was submitted.
Comment 1 Phil Knirsch 2006-11-07 10:56:59 EST
Setting bug to component distribution to get proper attention.

Read ya, Phil
Comment 4 Terry Rudd 2007-12-03 12:29:12 EST
This feature still remains a very interesting addition for large enterprise
customers for HP, doing huge database manipulations.  I am aware that Red Hat is
considering this feature for RHEL 6 but would still like to see it in a future
update for RHEL 5

Terry Rudd
Comment 5 Terry Rudd 2007-12-04 13:48:03 EST
Updated title to reflect likelyhood of feature in RHEL 6
Comment 6 Terry Rudd 2008-01-23 19:50:36 EST
HP still considers this a high-value deliverable for RHEL 6 for large cell-
based server systems and hopes that this feature can finally get into RHEL for 
a few large and important HP customers.
Comment 7 Bill Nottingham 2008-10-09 16:32:16 EDT

*** This bug has been marked as a duplicate of bug 435304 ***
Comment 8 Jan Iven 2008-10-10 02:44:52 EDT
435304 appears to be private - since this one is now closed , could you please make 435304 public?
Comment 9 Stuart McDow 2009-12-09 12:50:45 EST
Request that Bug 435304 be made public.  Thanks.
Comment 10 Eric Sandeen 2009-12-09 13:16:16 EST
(In reply to comment #9)
> Request that Bug 435304 be made public.  Thanks.  

I'll ask but it was opened by a partner and one never knows what may be considered sensitive.

If you have questions about xfs in RHEL you can probably get the most information from your sales or support folks, if that doesn't suffice, feel free to email me and we can put you in touch with the right people.


Note You need to log in before you can comment on or make changes to this bug.