Bug 213746 - LVMs "disappear" during installation
LVMs "disappear" during installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 15:31 EST by Jean Francois Martinez
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2006-11-02 15:31:41 EST
Description of problem:

LVMs "disappear" during installation (on a 224M machine)


Version-Release number of selected component (if applicable):
11.1.3-1

How reproducible:
Everytime


Steps to Reproduce:
1. Boot installation by restricting your machine to 224M
2. Use an LVM as / (be it a prexisting LVM or one you creatre during
installation).  I have not tried with other mount points like /usr
3.  At one point you get the warning that due to low memory, swap has to be
activated and thus, partition table written.  Click on OK
4.  When anaconda tries to format/mount the LVM it does not find it and
installation aborts
  
Actual results:
Installation aborts


Expected results:
Obvious

Additional info:
I redid the installtion and my LVMs were visible all of it then they disappeared
at this point  a /dev filesystem and that this was mounted <b>two</b> times.  So
my explanation is that  anaconda mounted that file system and activated the LVMs
so they became visible under /dev but the it mounted the /dev filesytem a second
time (probably from an image existing on the CD) and this hid the
/dev/VolGroup/LVM entries

The machine was 256 Meg RAM laptop whose video used 32 Megs RAM as Video memory
(thus the funny 224M RAM usable by Linux).  I don't know if machines with more
memory (where anaconda does not need to prematurealy write partition table and
activate swap) exhibit the same problem

I have tried both with a preexiting LVM and one created during installation with
identical results.

I am not sure I tried text mode.
Comment 1 Jeremy Katz 2006-11-06 10:29:12 EST
Can you provide the dump that you received?
Comment 2 Jean Francois Martinez 2006-11-09 14:46:12 EST
What dump?

If you are referring to the list of mounted volumes with /dev mounted two times
I redid the installation and this disn't reproduce so either the second /dev was
alreday ujnmounted when I checked, or I figured it out.  In case I didn't my
memory is that the second /dev mounted was at the end of the list when I did a
mount.

However what was _very_ reproducible is that installation did not complete: it
went to the checking dependencies phase then the preparing to install phase,
then to the next screen with the progress bar about installed software and at
this point it failed.   By shifting around virtual consoles I  saw that mkfs had
been unable to find the /dev/Vgroup/Lvolume file.

PS: I started install from a situation where machine had only ordinary
partitions, and one of them was deleted to make an LVM one from it. 
Comment 3 David Cantrell 2007-03-15 17:58:46 EDT
256MB of memory is the mimimum required for installation.  Even in those cases,
you should run the text mode installer.

Try rawhide or a Fedora 7 test release and see if the problem has been solved.
Comment 4 Red Hat Bugzilla 2007-06-11 23:22:22 EDT
requested by Jams Antill
Comment 5 Bug Zapper 2008-04-04 00:22:32 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2008-05-06 12:40:41 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.