Bug 213752 - Wrong video driver installed for S3 Savage
Wrong video driver installed for S3 Savage
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 15:49 EST by Bruce Korb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 13:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Korb 2006-11-02 15:49:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Fedora/1.5.0.4-1.2.fc5 Firefox/1.5.0.4 pango-text

Description of problem:
Your interface is too sucky to be able to select the X11 component.
I did an install and when done, the wrong driver was installed,
despite the fact it correctly identified the video card.  Locked up
my system.  No way out, despite many requests for help.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always


Steps to Reproduce:
1. get a system with an S3 Savage card
2. install
3. reboot

Actual Results:
Completely locked up.  Had to use rescue boot to alter boot level
from 5 to 3 so I could at least use it as a text system.

Expected Results:
X would come up.

Additional info:
I don't care a lot any more because it is clear FC6 needs work,
based on many comments.  I am back on SuSE 10.1.  Sorry.
Comment 1 Chris Lumens 2006-11-03 13:57:19 EST
We allow you to pick your video driver with a command line option to anaconda,
but we do not make this available through an interface component because it is
confusing to many users and is just unnecessary complication.  However the
command line option is there for emergency use.

Picking the wrong driver probably means that there is a problem with the X
detection code for your particular video card.  From your report, it sounds like
there could also be a problem with the X server itself.  There is information
from your machine that we could extract and attach to this bug that would be
useful to the X developers.  If  you would like to assist us in debugging this
problem, it would be helpful.  However since you don't care about this problem
anymore, it will probably stay broken unless someone else with the same hardware
reports the problem.  I'm closing this as CANTFIX for now on the basis of your
comments.  Feel free to reopen it if you'd like to help.
Comment 2 Bruce Korb 2006-11-06 11:19:08 EST
Well, I've loaded SuSE, so the installation logs are gone.  However, I have
the same hardware and BIOS, so if you tell me what to type, I can give you
that info.  Thanks - Bruce

Note You need to log in before you can comment on or make changes to this bug.