Bug 213801 - Encrypted removable media not automounted after opening
Encrypted removable media not automounted after opening
Status: CLOSED DUPLICATE of bug 216538
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 19:39 EST by Michael Hampton
Modified: 2013-03-05 22:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 20:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Hampton 2006-11-02 19:39:23 EST
Description of problem:

After inserting a removable USB drive, its partition is automounted with the
logged-in user's permissions, and an icon for the partition appears on the
desktop. However, after inserting a removable USB drive with a LUKS encrypted
partition, gnome-volume-manager prompts for the passphrase, creates a dm-crypt
mapping, but fails to automount the mapped partition.

Version-Release number of selected component (if applicable):

gnome-volume-manager-2.15.0-2.fc6

How reproducible:

Always

Steps to Reproduce:
1. Create an encrypted partition on a USB flash drive:
   cryptsetup luksFormat /dev/sda1 # Set a passphrase.
   cryptsetup luksOpen /dev/sda1 usbdisk # Enter passphrase.
   mkdosfs -n MyUSBDdrive -F32 /dev/mapper/usbdisk # Could also be ext2 or whatever
   cryptsetup luksClose usbdisk
   eject /dev/sda # And remove the USB flash drive
2. Insert USB flash drive. Passphrase prompt appears. Type in passphrase.
3. Mapping /dev/mapper/luks_crypto_{uuid} is created.
  
Actual results:

The mapping /dev/mapper/luks_crypto_{uuid} is not automatically mounted.

Expected results:

The mapping /dev/mapper/luks_crypto_{uuid} should be mounted at
/media/MyUSBDrive and a desktop icon presented to the user.

Additional info:
Comment 1 W. Michael Petullo 2006-11-20 19:59:10 EST
Michael, could you mark this as a duplicate of 216538?  I know this report was
entered first, but I think 216538 diagnoses the cause.
Comment 2 Michael Hampton 2006-11-20 20:07:26 EST
Sure, if I can manage to type the number correctly.

*** This bug has been marked as a duplicate of 216538 ***

Note You need to log in before you can comment on or make changes to this bug.