Bug 213854 - /dev/input/uinput not created
/dev/input/uinput not created
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 09:24 EST by Florian Festi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 08:05:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Festi 2006-11-03 09:24:10 EST
Version-Release number of selected component (if applicable):
udev-095-14.x86_64

Steps to Reproduce:
1. /sbin/modprobe uinput
2. ls -l /dev/input/
  
Actual results:

modules loads but device node is not created. If created manually with mknod
everything works fine.

Expected results:

udev should create the device node
Comment 1 Harald Hoyer 2006-11-03 09:39:47 EST
fix the kernel module..
Comment 2 Dave Jones 2007-02-04 14:24:32 EST
Florian, do you have a /sys/class/misc/uinput/dev ?
Comment 3 Florian Festi 2007-02-05 06:13:22 EST
After 
/sbin/modprobe uinput

/sys/class/misc/uinput/dev exists
/dev/input/uinput doesn't
Comment 4 Dave Jones 2007-02-05 17:19:38 EST
Then it isn't a kernel bug.
Harald, can you explain what led you to believe this was the case?
Comment 5 Harald Hoyer 2007-02-06 05:51:43 EST
Florian, does /dev/uinput exist?
Comment 6 Florian Festi 2007-02-06 06:10:59 EST
Oops, yes.

Is this the intended location for the device?
Comment 7 Harald Hoyer 2007-02-06 07:50:44 EST
no... will correct this

Note You need to log in before you can comment on or make changes to this bug.