Bug 213857 - tre-devel package does not contain static libraries
tre-devel package does not contain static libraries
Status: CLOSED DUPLICATE of bug 213859
Product: Fedora
Classification: Fedora
Component: tre (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 09:35 EST by Nico Kadel-Garcia
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 13:06:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nico Kadel-Garcia 2006-11-03 09:35:23 EST
Description of problem:
tre-devel package does not contain static libraries

Version-Release number of selected component (if applicable):
tre-0.7.4

How reproducible:
Run "rpm -ql tre-devel" on any default installed tre-devel RPM.

Steps to Reproduce:
1. Install tre-devel RPM with "yum install tre-devel".
2. Check contents with "rpm -ql tre-devel"
3.
  
Actual results:


Expected results:
There should be a libtre.a file included.

Additional info:
This is easily fixed by adding the "--enable-static" option to the %configure 
in the .spec file, and adding %{_libdir}/libtre.a to the list of files for 
the -devel package. I've contacted the software author, but he's in no rush to 
publish a new .spec file update.
Comment 1 Dominik 'Rathann' Mierzejewski 2006-11-03 13:06:27 EST

*** This bug has been marked as a duplicate of 213859 ***

Note You need to log in before you can comment on or make changes to this bug.