Bug 213867 - gdm hangs on every logout X86_64
gdm hangs on every logout X86_64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 10:20 EST by Nuno Carvalho
Modified: 2008-03-18 14:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs produced (85.06 KB, application/octet-stream)
2006-11-03 10:20 EST, Nuno Carvalho
no flags Details
/var/log/messages (67.83 KB, application/octet-stream)
2006-11-03 17:41 EST, Nuno Carvalho
no flags Details

  None (edit)
Description Nuno Carvalho 2006-11-03 10:20:01 EST
Description of problem:
When logging of the machine in graphical mode ( End Current Session, Turn Off
Computer and Restart) it simply hangs the system, I have to press reboot button
or turn it off. I happens all the time and on boot time it has to recover from
journaling. My system is a PIV 3.0Ghz EM64, Asus P4P800 SE motherboard, 1 GB of
memory and ATI 9250 SE video. Tried with open source radeon driver and with ati
(closed source) driver has well with the same result. In /var/log/messages this
line appears after trying to logout:

Nov  2 12:07:43 hxa-w006 gdm[2749]: Master halting...

or 

Nov  2 12:04:50 hxa-w006 gdm[2784]: Restarting computer...

This problem only occurs on X86_64 arch, in the i386 version there is no problem
 as I can logout properly.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6
gdm-2.16.0-18.fc6
xorg-x11-server-Xorg-1.1.1-47.fc6 (and all the other packages : driver, fonts,
utils, etc etc)
arch x86_64

How reproducible:
Happens every time I try to logout in the graphical mode with any option :
End Current Session
Turn Off Computer
Restart Computer

Steps to Reproduce:
1.Start the computer
2.Login graphical mode
3.Logout with any option
4.Hangs with black screen
  
Actual results:
Hangs with black screen

Expected results:
Logout properly.

Additional info:
Attched are the logs produced : dmesg, Xorg.0.log, xorg.conf, uname -a
Comment 1 Nuno Carvalho 2006-11-03 10:20:02 EST
Created attachment 140254 [details]
Logs produced
Comment 2 Nuno Carvalho 2006-11-03 17:41:39 EST
Created attachment 140334 [details]
/var/log/messages
Comment 3 J.Jansen 2006-11-08 10:58:57 EST
I do not see the problem at home where I have a machine with a P4P800 DELUXE
mother board, but ...

I get the same problem on my laptop : its an ACER ASPIRE 1700.
I upgraded this machine from FC5 (with no problems) to FC6. Additionally
I corrected the the kernel (from i586->i686 (anaconda bug)).
Comment 4 Ray Strode [halfline] 2006-11-08 11:28:59 EST
what version of rhgb do you have installed?
Comment 5 J.Jansen 2006-11-09 03:32:02 EST
On my Acer Aspire 1700 (note that since this is a i686 machine the architecture
tag and the title of this bug should be changed) I'm running
 rhgb.i386                                0.16.4-3.fc6           installed       
    


On my machine (which does not show the problem) at home I'm running the rhgb
which comes with the FC6 DVD. However, if I remember correctly also before
upgrading rhgb, so just after installing FC6 from DVD, I experienced the problem
on the Acer machine.


I have no idea why you suspect rhgb, since the problem does not appear at
boot-time, but at closing of a further succesful user-session.

                        Jouk
Comment 6 J.Jansen 2006-12-05 06:41:55 EST
Nothing changed after all the updates I installed over the last months.

However, I noticed something which may be related (or not). When the machine is
unattended (i.e. during the night) running xscreensaver on top of the
gnome-session I experience "logouts" at random times. (I already played with the
Power-saver options with no results) But after such an "automatic" logout I just
can login and logout again in the gnome session without the "hang" described
above. Before the "automatic" logout this is still impossible.

                      Jouk
Comment 7 Ray Strode [halfline] 2008-03-18 14:41:47 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.