Bug 2139092 - Update notifications don't show up in Plasma 5.26
Summary: Update notifications don't show up in Plasma 5.26
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-discover
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-01 12:14 UTC by Kamil Páral
Modified: 2022-11-08 01:49 UTC (History)
11 users (show)

Fixed In Version: plasma-discover-5.26.2-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-08 01:49:03 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
plasma 5.26 - notifications menu (375.37 KB, image/png)
2022-11-01 12:15 UTC, Kamil Páral
no flags Details
plasma 5.25 - banner (417.78 KB, image/png)
2022-11-01 12:15 UTC, Kamil Páral
no flags Details
plasma 5.25 - notifications menu (377.51 KB, image/png)
2022-11-01 12:15 UTC, Kamil Páral
no flags Details
rpm -qa in RC 1.5 (64.19 KB, text/plain)
2022-11-01 12:17 UTC, Kamil Páral
no flags Details
rpm -qa in RC 1.4 (64.17 KB, text/plain)
2022-11-01 12:17 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2022-11-01 12:14:50 UTC
Description of problem:
In F37 KDE RC 1.5 (which contains Plasma 5.26), new update notifications no longer show up. Only a small icon (an arrow in a circle) is shown in systray, but there's no notification banner popup, and it's also not listed in the Notifications menu.

In RC 1.4 (with Plasma 5.25.5), update notifications worked as expected.

We also see the same problem in OpenQA, so this is not just in my VM.


Version-Release number of selected component (if applicable):
BROKEN:
plasma-desktop-5.26.2-1.fc37.x86_64
plasma-discover-notifier-5.26.2-1.fc37.x86_64
kf5-knotifications-5.99.0-1.fc37.x86_64

WORKING:
plasma-desktop-5.25.5-1.fc37.x86_64
plasma-discover-notifier-5.25.5-1.fc37.x86_64
kf5-knotifications-5.98.0-1.fc37.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install F37 KDE RC 1.5
2. Enable updates-testing repo
3. Reboot
4. See that a systray icon shows up, but no notification popup

Comment 1 Kamil Páral 2022-11-01 12:15:46 UTC
Created attachment 1921533 [details]
plasma 5.26 - notifications menu

Comment 2 Kamil Páral 2022-11-01 12:15:50 UTC
Created attachment 1921534 [details]
plasma 5.25 - banner

Comment 3 Kamil Páral 2022-11-01 12:15:55 UTC
Created attachment 1921535 [details]
plasma 5.25 - notifications menu

Comment 4 Kamil Páral 2022-11-01 12:16:44 UTC
Comment 1 shows how it looks like in RC 1.5, comment 2 and comment 3 show how it looked like in RC 1.4.

Comment 5 Kamil Páral 2022-11-01 12:17:07 UTC
Created attachment 1921536 [details]
rpm -qa in RC 1.5

Comment 6 Kamil Páral 2022-11-01 12:17:16 UTC
Created attachment 1921537 [details]
rpm -qa in RC 1.4

Comment 7 Kamil Páral 2022-11-01 12:18:38 UTC
Proposing as a blocker:
"Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image. "
https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria#Update_notification

Please note that the systray icon could be considered satisfactory, even when a banner is missing. Proposing for a discussion.

Comment 8 Alessandro Astone 2022-11-01 12:29:30 UTC
Isn't it on purpose?
https://pointieststick.com/2022/08/26/this-week-in-kde-re-bindable-mouse-buttons/#new-features

> Discover now lets you choose the frequency with which it notifies you about new updates! And within those frequencies, it’s now less aggressive about notifying you; no longer will you have the experience of updating, rebooting, and then immediately getting a notification about another update

Comment 10 Kamil Páral 2022-11-01 12:46:31 UTC
Great findings, Alessandro. I looked at my settings and it's set to Daily. I should note that this is a clean installation, so whatever the value is, I wasn't notified before, and yet it still fails to produce the notification. Also, I installed the VM yesterday, but the notification isn't shown even today. But it's very likely that the change is related to the links you posted, thanks. The question is whether the lack of a banner notification is intentional or not.

Blocker discussion ticket is here:
https://pagure.io/fedora-qa/blocker-review/issue/1000

Comment 11 Carlos 2022-11-01 12:52:28 UTC
I think notifications should be set to weekly btw.

Comment 12 Adam Williamson 2022-11-01 16:32:59 UTC
oh god, now I have to defeat stupid KDE heuristics as well as stupid GNOME heuristics[0]? joy.

[0] https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/main/f/tests/desktop_notifications.pm#_28

the precedent here is when the desktop does clever-clever stuff like this, we defer to the relevant WG/SIG in determining what the 'intended' behaviour is, within reason. For e.g. if the intent is only that a notification will show up within a day of install, and that does work, we consider the criterion satisfied. So, we do need to get the KDE team's input here.

Comment 13 Adam Williamson 2022-11-01 16:38:51 UTC
Just eyeballing the code, there seems to be at least a possibility that it may have a bug causing update notifications never to be shown on new profiles. But that may not be the case, I'm not 100% sure. I'll try and test it out with some debug prints if nobody answers my question on the upstream commit.

Comment 14 Adam Williamson 2022-11-01 18:11:25 UTC
apol agreed with me that the code looked buggy, and now there's an MR upstream: https://invent.kde.org/plasma/discover/-/merge_requests/404 . I'm doing a scratch build with it backported and will try and hack that into the openQA test to see if it helps.

Comment 15 Adam Williamson 2022-11-01 20:47:00 UTC
It did help. I'm doing an official build now.

Comment 16 Fedora Update System 2022-11-01 21:42:01 UTC
FEDORA-2022-23a0a34ea5 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-23a0a34ea5

Comment 17 Kamil Páral 2022-11-02 07:19:41 UTC
(In reply to Fedora Update System from comment #16)
> FEDORA-2022-23a0a34ea5 has been submitted as an update to Fedora 37.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-23a0a34ea5

Tested, notifications show up now.

Comment 18 Fedora Update System 2022-11-02 13:34:09 UTC
FEDORA-2022-23a0a34ea5 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-23a0a34ea5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-23a0a34ea5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Adam Williamson 2022-11-02 19:52:19 UTC
I edited the fix for this into the same update that initially caused it, so it doesn't really need blocker status.

Comment 20 Fedora Update System 2022-11-08 01:49:03 UTC
FEDORA-2022-23a0a34ea5 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.