Bug 21394 - apmscript unloads sound module on resume instead of suspend
Summary: apmscript unloads sound module on resume instead of suspend
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-27 21:16 UTC by Patrick C. F. Ernzer
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 21:17:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick and dirty patch (5.35 KB, patch)
2000-11-27 21:17 UTC, Patrick C. F. Ernzer
no flags Details | Diff

Description Patrick C. F. Ernzer 2000-11-27 21:16:29 UTC
/etc/sysconfig/apm-scripts/apmscript unloads the sound modules on resume.
This leads to a crash on a Dell Latitude CPx J650GT. Unloading the module
on suspend fixes this.

I made a quick patch which can be e-mailed upon request.

Comment 1 Patrick C. F. Ernzer 2000-11-27 21:17:53 UTC
Created attachment 5749 [details]
quick and dirty patch

Comment 2 Bernhard Rosenkraenzer 2001-01-08 18:38:33 UTC
Fixed in 3.0final-26.
I've had to redo large parts of your patch because it introduces a couple of
nice ways to get a root shell...
e.g.

SOUNDUSER=`perl -e 's/\000/\n/g;' -p /proc/$SOUNDPID/environ|grep USER=|cut -d=
-f2`

Applications can overwrite the USER variable, or just set an AUSER variable that
would be matched first, so you could "re"start any program as root.



Note You need to log in before you can comment on or make changes to this bug.