Bug 21397 - Panel checks /proc/apm and dies a horrible flaming death
Summary: Panel checks /proc/apm and dies a horrible flaming death
Status: CLOSED DUPLICATE of bug 21185
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-27 21:36 UTC by Jp Robinson
Modified: 2013-04-02 04:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 21:49:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jp Robinson 2000-11-27 21:36:01 UTC
Apparently the panel is set to check /proc/apm upon startup and if it 
finds certain things in it, display the battery applet. However, this 
check will crash on certain computers with certain apm implementations. 
(Seems to be mostly laptops). I am quite sure that it is the panel that 
causes the crash as renaming/removing the battery_applet executable does 
not fix the problem, only booting with "linux apm=off" seems to help.

A hard-coded check of this sort of thing just seems wrong to me, 
especially when bugs like this crop up. Why not simply allow the user to 
start the applet on his own if he wishes? 

If there is a way to bypass this, please let us know, or possibly release 
a bugfix?

Jp Robinson, Consumer Support.

Comment 1 Bill Nottingham 2000-11-27 22:11:33 UTC
This is a hardware bug. The panel isn't doing anything
out of the ordinary.

*** This bug has been marked as a duplicate of 21185 ***


Note You need to log in before you can comment on or make changes to this bug.