Bug 213978 - Completion locks up under load
Completion locks up under load
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Graner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 02:18 EST by Kasper Dupont
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 11:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2006-11-04 02:18:18 EST
Description of problem:
Trying to complete file names under high load causes bash to lock up

Version-Release number of selected component (if applicable):
bash-3.1-9.fc5.1

How reproducible:
Did not try

Steps to Reproduce:
1. Run multiple processes causing paging/swapping
2. Try to complete a file name in bash
  
Actual results:
A list of file names is printed and bash locks up without displaying a new prompt.

Expected results:
Prompt returns after showing file names.

Additional info:
strace reveals bash is stuck in a futex call:
futex(0x3a00bc, FUTEX_WAIT, 2, NULL
Comment 1 Kasper Dupont 2006-11-04 02:20:40 EST
In case it is relevant the maps of the stuck process looks like this:
00200000-00219000 r-xp 00000000 03:06 3884754    /lib/ld-2.4.so
00219000-0021a000 r-xp 00018000 03:06 3884754    /lib/ld-2.4.so
0021a000-0021b000 rwxp 00019000 03:06 3884754    /lib/ld-2.4.so
00244000-00246000 r-xp 00000000 03:06 3884964    /lib/libdl-2.4.so
00246000-00247000 r-xp 00001000 03:06 3884964    /lib/libdl-2.4.so
00247000-00248000 rwxp 00002000 03:06 3884964    /lib/libdl-2.4.so
0026c000-0026f000 r-xp 00000000 03:06 3884162    /lib/libtermcap.so.2.0.8
0026f000-00270000 rwxp 00002000 03:06 3884162    /lib/libtermcap.so.2.0.8
00270000-0039d000 r-xp 00000000 03:06 3884834    /lib/libc-2.4.so
0039d000-0039f000 r-xp 0012d000 03:06 3884834    /lib/libc-2.4.so
0039f000-003a0000 rwxp 0012f000 03:06 3884834    /lib/libc-2.4.so
003a0000-003a3000 rwxp 003a0000 00:00 0 
00c31000-00c32000 r-xp 00c31000 00:00 0          [vdso]
00d4c000-00d4d000 r-xp 00000000 03:06 4096678    /usr/lib/gconv/ISO8859-1.so
00d4d000-00d4f000 rwxp 00000000 03:06 4096678    /usr/lib/gconv/ISO8859-1.so
00fbd000-00fc6000 r-xp 00000000 03:06 3885413    /lib/libnss_files-2.4.so
00fc6000-00fc7000 r-xp 00008000 03:06 3885413    /lib/libnss_files-2.4.so
00fc7000-00fc8000 rwxp 00009000 03:06 3885413    /lib/libnss_files-2.4.so
08047000-080f2000 r-xp 00000000 03:06 3885600    /bin/bash
080f2000-080f8000 rw-p 000aa000 03:06 3885600    /bin/bash
080f8000-080fc000 rw-p 080f8000 00:00 0 
096d6000-099a1000 rw-p 096d6000 00:00 0 
b7b9b000-b7bc7000 rw-p b7bbe000 00:00 0 
b7cc5000-b7ccc000 r--s 00000000 03:06 4096823    /usr/lib/gconv/gconv-modules.cache
b7ccc000-b7d01000 r--p 02b29000 03:06 4523776    /usr/lib/locale/locale-archive
b7d01000-b7f01000 r--p 00000000 03:06 4523776    /usr/lib/locale/locale-archive
b7f01000-b7f02000 rw-p b7f01000 00:00 0 
b7f1e000-b7f20000 rw-p b7f1e000 00:00 0 
b7f20000-b7f26000 r--p 012ad000 03:06 4523776    /usr/lib/locale/locale-archive
b7f26000-b7f27000 rw-p b7f26000 00:00 0 
bf856000-bf86c000 rw-p bf856000 00:00 0          [stack]
Comment 2 Tim Waugh 2006-11-07 06:12:39 EST
Please install bash-debuginfo-3.1-9.fc5.1 (from updates-debuginfo) and then
attach to the stuck process with 'gdb /bin/bash $PID' (with bash process ID in
$PID).

Then at the '(gdb)' prompt enter 'bt'.  What does it say?

Note You need to log in before you can comment on or make changes to this bug.