Bug 213984 - pand doesn't seem to call /etc/bluetooth/pan/dev-up
pand doesn't seem to call /etc/bluetooth/pan/dev-up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 04:27 EST by Håvard Wigtil
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 06:02:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Håvard Wigtil 2006-11-04 04:27:26 EST
Description of problem:
A PAN connection from my phone to my PC doesn't work like it used to pre
bluez-utils 3.7. It seems to me like the script /etc/bluetooth/pan/dev-up
doesn't get called.

Version-Release number of selected component (if applicable):
bluez-utils-3.7-2

How reproducible:
Always

Steps to Reproduce:
1. Start pand: "pand --listen --role NAP --nodetach"
2. Connect from phone
  
Actual results:
Can't ping phone, no connection

Expected results:
Working connection.

Additional info:
If I run /etc/bluetooth/pan/dev-up manually afterwards then the connection works.
I've inserted logging statements into the script, and it seems like it doesn't
get called at all. I had this working after I installed FC6, and I think it
broke with the 3.7 upgrade.
Comment 1 David Woodhouse 2007-07-21 06:02:54 EDT
Hm. We no longer run /etc/bluetooth/pan/dev-up automatically; there is a '-u'
option to pand which tells it which script to run. You'd have to add '-u
/etc/bluetooth/pand/dev-up' to pand's arguments to preserve the old behaviour.

The man page seems to be already fixed upstream; I've pulled in the patch:
http://git.infradead.org/?p=bluez-utils.git;a=commitdiff;h=8bb7406477a60e1c1ad343386cd1ecd81d0ced2a

Note You need to log in before you can comment on or make changes to this bug.