Bug 2139842 - vim upgrade broke :! for displaying terminal output
Summary: vim upgrade broke :! for displaying terminal output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-03 15:44 UTC by Kevin Wolf
Modified: 2022-11-10 22:32 UTC (History)
3 users (show)

Fixed In Version: vim-9.0.828-1.fc36 vim-9.0.828-1.fc35 vim-9.0.828-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-05 16:59:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Wolf 2022-11-03 15:44:54 UTC
Description of problem:
One quick way to switch to the terminal output (either from before starting the editor, or for commands executed from inside it) has always been the sequence ':!'. It would wait for you to press the enter key to return to the editor view. This doesn't work any more after the latest package update, the sequence doesn't do anything any more. The desired old behaviour is still observed with a non-empty shell command like ':!echo'.

Version-Release number of selected component (if applicable):
vim-common-2:9.0.803-1.fc35.x86_64
vim-enhanced-2:9.0.803-1.fc35.x86_64
vim-minimal-2:9.0.803-1.fc35.x86_64
vim-data-2:9.0.803-1.fc35.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start 'vim' (no command line arguments necessary)
2. Type ':!'

Actual results:
Nothing happens.

Expected results:
The terminal content from before starting the editor is visible, with a message "Press ENTER or type command to continue".

Additional info:
The expected behaviour is restored after a downgrade to vim-*-2:9.0.720-1.fc35.x86_64

Comment 1 Zdenek Dohnal 2022-11-04 12:45:48 UTC
Hi Kevin,

thank you for reporting the issue!

It is fixed with the latest patchlevel 828, which is in updates testing for F37 and F36 and now (because yesterday F35 branches were locked...) I'm building it for F35.

Comment 2 Fedora Update System 2022-11-04 12:47:07 UTC
FEDORA-2022-4bc60c32a2 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4bc60c32a2

Comment 3 Fedora Update System 2022-11-04 12:47:16 UTC
FEDORA-2022-06e4f1dd58 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-06e4f1dd58

Comment 4 Fedora Update System 2022-11-04 13:23:04 UTC
FEDORA-2022-3d354ef0fb has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3d354ef0fb

Comment 5 Fedora Update System 2022-11-05 16:59:53 UTC
FEDORA-2022-06e4f1dd58 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2022-11-05 17:54:15 UTC
FEDORA-2022-3d354ef0fb has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-3d354ef0fb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-3d354ef0fb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-11-09 11:27:02 UTC
FEDORA-2022-3d354ef0fb has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2022-11-10 22:32:03 UTC
FEDORA-2022-4bc60c32a2 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.