Bug 214019 - Better label/location for "Math/Science" Categories in applications menu
Better label/location for "Math/Science" Categories in applications menu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 12:07 EST by Tadej Janež
Modified: 2008-03-18 14:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2006-11-04 12:07:22 EST
Description of problem:
xmaxima launcher is currently located under Edutainment in my applications menu,
along with kdeedu packages and I think it is really hard to find.
I think we shoud put it under the Programming menu (or create a new Science
menu, perhaps?) along with GNU Octave, Mathematica, etc.

Version-Release number of selected component (if applicable):
maxima-gui-5.10.0-5.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2006-11-22 10:18:37 EST
FYI, xmaxima currently includes
Categories=Science;Education;Math;
and appears for me (in kde) in Edutainment->Science and Edutainment->Math

Offhand, I can see dropping Science, but I'd lean against labeling xmaxima as a
Development (though I can see the argument for it).  Hmm... maybe IDE?

See
http://standards.freedesktop.org/menu-spec/latest/apa.html
what menu categories do you think should best apply to xmaxima (other than the
obvious "Math")?  If that question can't be answered, the problem lies more with
redhat-menus and how it organizes the Categories, not here what what Categories
apply to maxima.
Comment 2 Tadej Janež 2006-11-22 10:48:12 EST
Hi!

I'm using gnome myself, but I have the kdeedu package installed. So, xmaxima
appers for me in Edutainment menu along with all kdeedu applications.
Edutainment only has one submenu called Miscellaneous with a single entry:
KWordQuiz (that seems strange to me, and it appeared only recently).

I see the problem now. I read the menu-spec and I see that your categorisation
seems to be the right one. I don't know about IDE, but it doesn't describe the
software very correctly. I checked the octave package and mathematica(non-free),
because they are, in my optinion, very close to xmaxima in functionality and
their categorisation is:
- GNU Octave:
Categories=Development;Math;Science;X-Fedora;

- Mathematica (non-free DUKE nosrc package):
Categories=Application;Development;X-Linux-At-Duke;

Note: they both appear in Programming in my gnome menu.

They obviously don't follow the menu-spec very closely, however, their location
in my menu seems to be more reasonable. What I dislike most right now, is the
heading Edutainment. I would never look for xmaxima in 'some sort of
entertainment' menu. It should at least be called Education and Science (or
similar). Maxima is a serious tool and this situation just doesn't feel right to me.

Should I rather persue a change in redhat-menus to change the name of
Edutainment menu to something else, if it is to be used by software such as
xmaxima? However, I'm afraid such a change is even more unlikely.

Thank you for looking into this!
Comment 3 Rex Dieter 2006-11-22 10:59:01 EST
Thanks for the feedback.  I think we agree that hacking Categories= improperly
to just get what we want is the wrong approach, so I'll reassign this FE/maxima
-> FC/redhat-menus, and adjust Summary accordingly.
Comment 4 Rex Dieter 2006-11-22 11:00:30 EST
completing FE-6/maxima -> FC-6/redhat-menus re-assignment
Comment 5 Ray Strode [halfline] 2008-03-18 14:40:39 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.