Bug 214023 - Suspend to Memory/Wake Fails on FC6
Suspend to Memory/Wake Fails on FC6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 14:46 EST by Garry T. Williams
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 18:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garry T. Williams 2006-11-04 14:46:17 EST
Description of problem:
Suspend to memory fails to wake properly since installing FC6.  This worked on
FC5 (2.6.18-1.2200.fc5).


Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6

How reproducible:
Always.

Steps to Reproduce:
1.  Configure klaptop to suspend on lid close.
2.  Close lid.
3.  Reopen and hit any key on keyboard.
  
Actual results:
Display is powered off.  I can ssh in from another machine and see that my KDE
session is still running.

Expected results:
Display should be restored.

Additional info:
I'm unsure of the component.

System is Sony Vaio VGN FS640W.

Suspend/wake originally worked in FC4 using custom scripts.  FC5 brought
pm-utils to KDE and this worked until 2.6.17 kernels.  All 2.6.17 kernels failed
with the same symptom (display never comes back up, but system is alive). 
Finally, 2.6.18-1.2200.fc5 fixed this.  Now FC6 breaks it again.
Comment 1 Marcelo 2006-11-23 15:43:47 EST
Exactly the same symptoms here, except that I didn't have this notebook before
kernel 2.6.17 and therefore did not test with older kernels. But the video did
not come back after a suspend with kernel 2.6.17; then the problem was corrected
with 2.6.18 in FC5; and now wake up from suspend doesn't work again with FC6.
I can verify that the system is running after wake up from suspend, but the
display remains off.
This is a centrino notebook with i915GM video chipset.
Comment 2 Marcelo 2006-11-26 19:56:10 EST
Maybe this bug is not kernel related. I think it may have something to do with
the following bug in upstream xorg:
https://bugs.freedesktop.org/show_bug.cgi?id=8542

This bug have been solved there. Has the patch been included in FC6's xorg?
Comment 3 Nigel Cunningham 2006-12-03 17:02:10 EST
Changing component to xorg-x11-drv-i810 since this does indeed seem to be a 
X-org driver issue rather than a kernel issue.
Comment 4 Garry T. Williams 2006-12-04 18:52:19 EST
OK.  I installed a new driver from http://www.fairlite.demon.co.uk/intel.html .

This does fix the problem.

I checked updates-testing and there is no xorg-x11-drv-i810 available.  The copy
from the above site reports:

(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(II) Module i810: vendor="X.Org Foundation"
        compiled for 7.1.99.2, module version = 1.7.2
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.0
Comment 5 Andrew Bartlett 2007-02-11 02:38:47 EST
This exact issue still occours with FC7 test 1, except I can get a 'bloom'
(white display creeping in from the outside of the LDC in a very artistic
fashion) on the screen if I hit a key.

xorg-x11-drv-i810-1.6.5-10.fc7
xorg-x11-server-Xorg-1.2.0-1.fc7
Comment 6 Marcelo 2007-05-01 11:41:06 EDT
I've got a new notebook with Intel i945GM video chipset and the problem is
slightly different with this one: the display is turned on when the notebook
resumes from suspend to RAM, but the backlight remains off.
The new i810 driver from http://www.fairlite.demon.co.uk/intel.html did not
solve this problem.
The same problem still occurs in Fedora 7 test 4.
Comment 7 Marcelo 2007-05-01 11:58:59 EDT
A correction on my last message: resume does work correctly with this notebook
in Fedora 7 test 4. Don't know what went wrong in the first time I tested it.
Comment 8 Matěj Cepl 2007-10-22 18:14:02 EDT
Closing per comment 7.

Note You need to log in before you can comment on or make changes to this bug.