Bug 214048 - Bug in rendering ASCII space character
Bug in rendering ASCII space character
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
: EasyFix, Patch
Depends On:
Blocks: 208527 215760
  Show dependency treegraph
 
Reported: 2006-11-04 23:03 EST by Trevin Beattie
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 13:11:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to bring src/util/ftutil.c up from 1.22 to 1.24 (770 bytes, patch)
2006-11-04 23:03 EST, Trevin Beattie
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 208527 None None None Never

  None (edit)
Description Trevin Beattie 2006-11-04 23:03:16 EST
Description of problem:
freetype returns an "invalid argument" error (6) when rendering character code
32 (if there are no strokes in the glyph) because it leads to allocating a
0-length block of memory and ftutil.c considers that an error.

Version-Release number of selected component (if applicable):
freetype-2.2.1-10

How reproducible:
Always.  An example of a program that is affected by this bug is tuxtype2, which
segfaults immediately on startup (trying to dereference a null pointer).

Steps to Reproduce:
1. Install tuxtype2 from the Fedora 6 Extras collection
2. Run tuxtype2
  
Actual results:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209043264 (LWP 26955)]
black_outline (t=0x80594c9 "Fish Cascade", font=0xa0b00e0, c=0x805fe28) at
alphabet.c:123
123             out = SDL_CreateRGBSurface(SDL_SWSURFACE, (tmp->w)+5,
(tmp->h)+5, 32, rmask, gmask, bmask, amask);
(gdb) bt
#0  black_outline (t=0x80594c9 "Fish Cascade", font=0xa0b00e0, c=0x805fe28) at
alphabet.c:123
#1  0x0804f51b in TitleScreen_load_menu () at titlescreen.c:75
#2  0x0804fdf4 in TitleScreen () at titlescreen.c:293
#3  0x0804e1b5 in main (argc=2, argv=0xbf888d84) at main.c:151
#4  0x00151f2c in __libc_start_main


Expected results:
Program should display rendered text.


Additional info:
The fix can be found on
http://cvs.savannah.gnu.org/viewcvs/freetype2/src/base/ftutil.c
Comment 1 Trevin Beattie 2006-11-04 23:03:16 EST
Created attachment 140377 [details]
Patch to bring src/util/ftutil.c up from 1.22 to 1.24
Comment 2 Steven Pritchard 2006-11-15 11:53:58 EST
Ping?
Comment 3 Behdad Esfahbod 2006-11-24 18:20:48 EST
Fixed in freetype-2.2.1-14.fc6 submitted for Update Testing.
Comment 4 Steven Pritchard 2006-11-27 20:00:21 EST
That fixes the bug in tuxtype2.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.